Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Cadillac
Joined
·
3 Posts
Discussion Starter #1
I'm not sure if this is trivial or what, but my battery died lastnight/this morning. I was able to get a jump from my friend and the car starts and runs fine now.
The problem is that my gas gage is stuck on E even tho i just filled it up, and when i toggle through the info all the info spaces are blank. How can i fix this? do i need to reset the computer or something? Thank you
 

·
Registered
2001 Seville SLS 140k miles
Joined
·
50 Posts
I cannot promise that this will work but you can try holding the info up button and the reset button at the same time for about 5 or 10 seconds, every light on the dash and cd player / climate control should light up momentarily. Hope this helps
 

·
Registered
Cadillac
Joined
·
3 Posts
Discussion Starter #3
I did that and it brought up some menu that searched for codes or something. It said it found 0 codes and just went back to the same choices. It didn't fix my gauges. Any other ideas?
 

·
Registered
1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
Joined
·
6,405 Posts
Disconnect the battery for 15 minutes or so and try from there…
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
70,711 Posts
STS, Update your profile with the year, model, and mileage of your car. It makes a very big difference when trying to figure out what's wrong.

Take a look at N*Caddy's and my profile to see what to insert.
 
1 - 5 of 5 Posts
Top