Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
97 Seville STS
Joined
·
22 Posts
Discussion Starter #1
Replaced the EGR, and many other parts, engine runs very rough, but HAS run well for short periods. Looking for how to access the "other" codes, Not the E 30 type ones, as we have done that. Plus, if there is a list or link to the procedure and what the normal parameters for a 4.9 in a '92 Deville, I'd appreciate that info as well. We have done SO much to this engine and are running out of ideas. Previously, it had run well on startup and crapped out when it got hot, but now it just runs rough at startup. This is a real quandry, we have NOT had this kind of trouble diagnosing and repairing any other vehicle before. Help please!
 

·
Registered
1995 FWB 128,*** miles
Joined
·
2,247 Posts
There is a ground on the engine block by the starter. It may look good, but disconnecting, cleaning , replacing the star washer and 8 mm x 1.25 mm stud never hurts. Another possibility is ECM which is under the glove box. You can unscrew the glove box and will see ECM, BCM and the programmer (climate control unit). Tap on the ECM when the engine acts up and see if it makes a difference. your problem sounds like an electrical one to me.
 

·
Registered
97 Seville STS
Joined
·
22 Posts
Discussion Starter #3
HUF, all indications are that it IS an electrical problem. Chasing it down has proved challenging and it seems like there are not enough hours in the day, KWIM? We'll give those tips a try and come back with an update. I would LOVE it to be something simple.
 
1 - 3 of 3 Posts
Top