Cadillac Owners Forum banner

21 - 24 of 24 Posts

·
Registered
2013 Cadillac CTS Coupe 3.6
Joined
·
20 Posts
My 2013 CTS coupe, with 14,000 miles, had a very dead battery that possibly triggered the code of bad alternator. Indie garage guy that I’ve used before put in a new battery and said the computer shows I need a new alt. He could install it for $950.00! I couldn’t believe it needed replacing so i said no thanks, just the battery. That was 6 months ago and no electrical problems since. Was he trying to rip me off?
 

·
Registered
2009 CTS 3.6L DI rebuilt to FE3 J55 G80 3.42:1
Joined
·
907 Posts
My 2013 CTS coupe, with 14,000 miles, had a very dead battery that possibly triggered the code of bad alternator. Indie garage guy that I’ve used before put in a new battery and said the computer shows I need a new alt. He could install it for $950.00! I couldn’t believe it needed replacing so i said no thanks, just the battery. That was 6 months ago and no electrical problems since. Was he trying to rip me off?
Maybe, maybe not. It's hard to say based on a paragraph in a forum that lacks parameters like voltage.

My alternator had a wounded rectifier bridge (turns the AC into DC in the alternator using diodes) from the day I bought it used in 2018. It still kept the battery charged, but didn't boost the voltage as high as the computer called for sometimes, like when the PCM commanded extra voltage for climate control or headlights. But it "still worked", and didn't even light the error light on the dash. Until one day it did. After replacing the alternator (see my previous link) I realized the voltage had been slightly low the whole time I owned the car.

The point is these alternators are known for burning out rectifiers, and sometimes that results in weak instead of totally dead. Did you ever get the "service charging system now" light? When you start the car on a cold morning does it push the voltage up to 14.8 to 15.0V within a few minutes, as shown in the DIC? Or does it only go up to 13.8 to 14.2V, normal for some older cars? Do you ever hear a faint whine when the car is under a heavy electrical load?
 
21 - 24 of 24 Posts
Top