Cadillac Owners Forum banner

1 - 16 of 16 Posts

·
Registered
Cadillac
Joined
·
100 Posts
Discussion Starter #1
Hi

Just got my 69 Deville running really well, after a year of fiddling and expensive upgrades.

Picked up a friend last night. Heard an intermittent clacking sound, sounded like the fan was chafing off something. Really LOUD had people on the street staring at me like I was a real car-abuser .. NOT SO ......

Looked into the engine with my torch, but couldn't see anything touching the fan, drove on and over a bump and it stopped ! Only to return after another bump with more of a 'huey chopper' sound (best description)

A friend told me before that my water pump belt was loose - could this be the problem. Does anyone know how to tighten/replace this?
I have noticed on WOT there is a bit of belt noise also.
Or, could something be actually inside the engine loose? timing chain or other mechanicals??

Car at the moment sounds like a WWII fighter plane that has been shot down.....

So any help received, is appreciated greatly.

Jon
 

·
Super Moderator
2014 ELR
Joined
·
9,838 Posts
It sounds like an exhaust leak to me. Belts, or lack of belts, don't make noises like you are describing. Get it in to a shop for a diagnosis.

Are you in Britain, or are you British?
 

·
Registered
1986 Fleetwood Brougham
Joined
·
77 Posts
Unless you try to isolate the problem to at least a general area, this could be anything from cracked exhaust to loose torque converter bolts to a loose pulley, etc.
Noise coming from top, front, side of engine, underneath?

It's just a guessing game at this point unfortunately.
 

·
Registered
Cadillac
Joined
·
100 Posts
Discussion Starter #5
Thanks for your replies.

I am trying to locate the noise.

New info:
the sound lessens when the engine has been driven for 30 mins, then goes away after a few decent acceleration runs.

Also, I had a backfire a few weeks ago which blew a small crack in my exhaust manifold. had it welded and everything was fine. So exhaust is a possiblility.

I described the sound badly before. I reckon that it is more of a hollow metallic sound that is only heard at idle. Been trying to isolate the sound by listening with some rubber tube as a stethoscope will post when I can isolate it more

Thanks

Jon
 

·
Super Moderator
2014 ELR
Joined
·
9,838 Posts
New info:
the sound lessens when the engine has been driven for 30 mins, then goes away after a few decent acceleration runs.

Also, I had a backfire a few weeks ago which blew a small crack in my exhaust manifold. had it welded and everything was fine. So exhaust is a possiblility.



Jon
The noise that goes away is the key. You have a crack in an exhaust manifold. It makes noise when you first start the car. As the car heats up, the metal expands, and the crack closes. Time to change the manifold. Don't go back to the place that "fixed" it...
 

·
Registered
Cadillac
Joined
·
100 Posts
Discussion Starter #8
Update

The sound is now much less, still there but much quieter than the engine sound.. all I did was add some octane booster.

Could this have been engine knock?

Any ideas why this sound would suddenly go away?

Cheers

Jon

ps I am in Ireland. not that that has anything to do with it - our fuel, usually only one type, is the equivalent to US 91/2 octane (called 95 here)
 

·
Registered
1986 Fleetwood Brougham
Joined
·
77 Posts
No way a sound as loud as you describe would be engine knock - those pistons would be sticking out of the block by now. Your car should run fine on 87 octane so 91-95 is certainly sufficient to prevent detonation.
I think that adding the booster and the sound decreasing is only coincidence - there is something else going on. You really need to isolate the location of the noise. Hopefully it is external and not internal!
 

·
Registered
Cadillac
Joined
·
100 Posts
Discussion Starter #12
Re: Horrible Engine noise SOLVED

It was a seizing AC compressor.

It finally froze up and melted the drive belt before I figured it out !

I got a resized power steering / air pump belt and bypassed the compressor.

Sorted !

thanks for the suggestions
 

·
Registered
1987 Cadillac Fleetwood Brougham
Joined
·
125 Posts
I had the problem w/ my '84 Chevy.. when the compressor would engauge, the pully would seize. I needed to use the front defrost (Which engauged the AC) so just removed power to the pump. Now it just acts as a tensioner.

Question though, by bypassing the pump all together, are you causing an uneven load on the crank? I tensioned my belts wrong once and it did that and caused my main seal to bleed some oil. Thank god I figured what the cause was before I bent the crank and caused myself a real headache. :)
 

·
Registered
1989 Brougham d'Elegance, 1985 Fleetwood Brougham *Coupe*
Joined
·
4,256 Posts
Re: Horrible Engine noise SOLVED

^The AC Compressor was starting to go...

It was a seizing AC compressor.

It finally froze up and melted the drive belt before I figured it out !

I got a resized power steering / air pump belt and bypassed the compressor.

Sorted !

thanks for the suggestions
 

·
Registered
Orange And Purple Lights.
Joined
·
6,632 Posts
Wow I only just found this thread.

Wouldn't have been much help, methinks.

Oh well. Nice car though, I'd kill for some photos.
 
1 - 16 of 16 Posts
Top