Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #1
Hey ive noticed that when im drivin my ETC on the interstate and im goin like 80 my rpms are at about 2700 rpms. Is that normal sry if i sound stupid on this but my moms Deville and my dads STS Seville dont rpm that high around those speeds. Plus i have an Z rated tire (orginally Z's too) and my car seems to run outta umhp at 110ish i sure if im goin down hill i could be goin faster lol but i thought they had no problem hittin 150 my dads 93 ETC i had up to 145 no problem but this 97 ETC seems to be struggleing
 

·
Registered
Joined
·
1,406 Posts
It sounds like you don't have overdrive. Like it is cruising in 3rd gear. Drop it down to third at 65 and see if it downshifts.
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #3
when i drop it into 3 i def feel it pull back so im assumin od is workin
 

·
Registered
Joined
·
161 Posts
CadillacETC1997 said:
Hey ive noticed that when im drivin my ETC on the interstate and im goin like 80 my rpms are at about 2700 rpms. Is that normal sry if i sound stupid on this but my moms Deville and my dads STS Seville dont rpm that high around those speeds. Plus i have an Z rated tire (orginally Z's too) and my car seems to run outta umhp at 110ish i sure if im goin down hill i could be goin faster lol but i thought they had no problem hittin 150 my dads 93 ETC i had up to 145 no problem but this 97 ETC seems to be struggleing
2700 sounds about right. Deville should have lower RPM due to different gears ratios. Not sure what year your dad's STS is. If your car came originally with the Z rated tires, you should be able to hit 150...but why would you need to? Oh...18 y/o...and we wonder why insurance costs so much these days :helpless:
 

·
Registered
Joined
·
1,406 Posts
My Seville cruises 80 at 2200 RPM. The whole 110MPH sounds like it didn't come with the Z rated package from the factory.
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #8
Ok thanks alot the only reason im concerned is only after having the car for 4 days one of the main oil pressure lines came lose losing all the oil so the motor went. The dealer replaced it and I wasnt sure if the tranny was adjusted right (via the throttle cable and such) plus i was wondering if there was any way i could make sure they put a VIN 9 motor in and not a VIN Y... I kno the ETC supposed to have the 9 but ive had some issues with the dealer and i wanted to make sure they didnt screw me
 

·
Banned
1995 ETC, 75 Deville, Cad500 powered 73 Apollo, 94 Mark VIII
Joined
·
7,971 Posts
CadillacETC1997 said:
Ok thanks alot the only reason im concerned is only after having the car for 4 days one of the main oil pressure lines came lose losing all the oil so the motor went. The dealer replaced it and I wasnt sure if the tranny was adjusted right (via the throttle cable and such) plus i was wondering if there was any way i could make sure they put a VIN 9 motor in and not a VIN Y... I kno the ETC supposed to have the 9 but ive had some issues with the dealer and i wanted to make sure they didnt screw me
There should be a VIN stamped somewhere on the engine. I dunno where, however. Someone who knows or has a FSM might be able to tell you.
 
1 - 10 of 10 Posts
Top