Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
SRX Performance
Joined
·
48 Posts
Discussion Starter #1
My car is a 2012 SRX Performance with about 28k miles. I have had this car since November of 2014.

The car has a very high pitched and loud squealing sound. The engine is off and nothing is powered on. The condition occurs any time you turn off the engine and exit the vehicle. It also occurs when any any function on the remote is activated. It also happens sometimes at seemingly random times. The car is garage kept so this may be why i notice the sound since its a closed environment.
One other issue the car has that may or may not be related is that the key less remote range is the worst I have ever seen. You need to be within 5 to 10 feet of the car for any functions to work. All of the remtes have new batteries.

Any help or suggestions appreciated
RG
 

·
Registered
2010 SRX
Joined
·
188 Posts
At first blush it sounds like an electronics issue. Did it just start? Did it coincide with the keyless entry issue?

My fob works within several yards with an original battery.

If the warranty is still valid, have your dealer check it out. Somethin' ain't right...
 

·
Registered
SRX Performance
Joined
·
48 Posts
Discussion Starter #3
I certainly plan to have the dealership look at it and figure out what the issue is. The reason for my post was to see if anyone else had experienced this same problem and it looks like no one has. It always worries me if the dealer doesn't have a similar problem they have dealt with because it always means extended shop time. I am still under warranty lucky for me!
 

·
Registered
2010 SRX
Joined
·
188 Posts
The only thing I had close to that was over a year ago when my car made a 'whirring/clicking' sound after I shut the engine off. The sound continued for several hours. I jumped on the forum and a knowledgeable person tutored me on 'actuators' in the car that can cause this. The next morning the sound was gone and it never returned. Have the dealer check anyway, but if it's not doing it when you get there, they may not be able to find it. Good luck.
 
T

·
Guest
Joined
·
0 Posts
Mine is 5 years old and had it since day one. It is a electronic system on and shuts down after a few minutes. Most noticeable in a quiet garage. I most notice it after using the fob and it goes off shortly there after. I think if you take it to the dealer for this you are wasting your time and will get the "no problem found response".
 

·
Registered
'14 SRX4 Premium silver-coast/shale-brownstone
Joined
·
790 Posts
Mine is the same as Traron. I would discribe it as a faint high-pitched electrical hum when I approach the vehicle with the fob. Like the car wakes up sensing the fob presence and electrically powers up ready to accept a door button push, or remote usage. Not a squeal or anything loud.

Max
 

·
Registered
SRX Performance
Joined
·
48 Posts
Discussion Starter #7
I'm guessing that maybe the overall volume of the sound may vary car to car. It doesn't bug me so much as I thought maybe it was some sort of defect. You would think they would want to mask that sound a little better to avoid complaints.

And hey I'm old and cant hear that great so what happens when people that CAN hear hear it?????
 
1 - 7 of 7 Posts
Top