Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
2006 STS
Joined
·
1 Posts
Discussion Starter #1
Hi, first time poster occasional reader... i have a 2006 STS that I got for my wife... So far I changed the sparks and one coil that was bad to eliminate a Misfire on 5 code.. I had my windows tinted .. And I changed the stock Brakes to Slotted and drilled rotors,.. But now im getting a high pitched squeel that comes right out of the sub woofer I tried closing doors.. moving settings,.. and then it just stops... 20 to 30 minutes later you could be cruisinb along and WEEEEEEEEEEEEEEEEEE.. I had heard some one say that they had a problem with a Bose system that sounded similar to my problem... when I disconect the bose amp.... no Sound..... no squeel.....Is my amp blown or is the Woofer gone... Dont know how to diagnose.. Any Ideas?
 

·
Registered
2006 STS4 V8 1SG & 2007 STS V8 1SE
Joined
·
8,178 Posts
Re: High pithed Squeel Bose

Every time I've read a member post this issue, it's been the amp. If you go with one from eBay, take precautions. It would be worth checking with an auto-recycler or do some searches. Almost all those recyclers belong to networks and there are folks that rebuild Bose components.

Good Luck.
 

·
Registered
2006 STS V8 1SF RWD
Joined
·
6,479 Posts
Re: High pithed Squeel Bose

It's NOT the main amp, it's the amp for the subwoofer - I had the same issue - under the rear seat is a fuse box, pull the rear shelf speaker fuse to make it stop for good, you'll lose your sub but it's better than that annoying sound. Luckily I have an aftermarket sub in the trunk so I don't really care much.

The amp/rear sub are one unit - RockAuto as new replacements for $190, but might have better luck finding a cheaper used option via eBay or a salvage yard.
 

·
Registered
2006 STS4 V8 1SG & 2007 STS V8 1SE
Joined
·
8,178 Posts
Thanks Curt.

Do you recall the base sound system being susceptible to anything similar?
 

·
Registered
2016 XTS FWD Platinum
Joined
·
1,084 Posts
It's definitely the sub in the rear package shelf. It has it's own amp built in. I couldn't take the noise anymore so I ended up replacing it & no more noise! And, I got bass back! I didn't realize i had lost it! lol

Max
 

·
Registered
2006 STS 4 AWD 3.6
Joined
·
105 Posts
This has happened to my Sub-woofer in my Bose system as well. The piercing squeal is unbearable and extremely stressful to listen to when it happens when you are driving.

I found that 15 Amp fuse (located under the rear seat...driver's side) and yanked the SOB right on out.

Now, can someone post up on how to remove/replace the sub-woofer ?


TIA
 
1 - 7 of 7 Posts
Top