Cadillac Owners Forum banner

1 - 13 of 13 Posts

·
Registered
97eldoradoETC
Joined
·
134 Posts
Discussion Starter #1
ok so i get in my car to leave work yesterday and when i fired it up i noticed it revved up pretty high. while i was idling through the parking lot it actually switched into second gear. if anyone has dealt with this or has any ideas what to check please let me know as soon as possible, trying to get it fixed today on my day off
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,999 Posts
Have you pulled the DTC's? Have you ever cleaned the TB?
 

·
Registered
96 SLS
Joined
·
160 Posts
Mine would idle high only when ending a long trip (50+ miles on interstate). I would exit and car would rev high. If I released brake car would take off. I would put the car in neutral and turn it off. Then I would restart and everything was back to normal. I figured it was the transmission speed sensors since the only code I had was the P0717. No longer have that code since I had tohave trans rebuilt.
 

·
Registered
97eldoradoETC
Joined
·
134 Posts
Discussion Starter #4
ok so i ran the codes earlier today and then researched them tonight and this is what ive come up with so far (these are the exact descriptions from the website i check to find out what they mean.) i know some of them dont really have anything to do with the problem but i figure ill throw them on here anyway and see if anyone can give me any insight about them...i also tried disconnecting the battery for about an hour to reset the iac.

PCM
P0122 - throttle position sensor/ switch A circuit low input.
P0603 - internal control module keep alive memory (KAM) error.
P1122 - throttle position (TP) sensor circuit internittent low voltage.

IPC
B1552 - decklid release circuit open (also got this code under PZM but not sure if its the same thing or not)

PZM
B1552 - ^^^
B1558 - ignition run/start circuit short to ground

TCS
C1255 - ABS inlet valve coil RR circuit open
 

·
Registered
97eldoradoETC
Joined
·
134 Posts
Discussion Starter #5
ok so we just cleaned the throttle body out (which was filthy) and let it run for a few and it seems to be idling normal now... hopefully thats all its gonna take
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,999 Posts
Kind of what I expected. When they are neglected, the carbon will build up bad enough that the throttle plate will not close completely, thus a high idle.
 

·
Registered
1993 Cadillac STS 4.6L N*
Joined
·
11 Posts
this does have a little bit to do with a high idle. it is a problem i have only seen twice and that is a cracked plenum sucking to much air causing a high idle. rare problem but does happen.
 

·
Registered
97eldoradoETC
Joined
·
134 Posts
Discussion Starter #8
well i went out and drove it around for about 15 minutes last night and gave it a couple wots and it blew a TON of smoke out, but everything seems to be running fine
 

·
Registered
1993 Cadillac STS 4.6L N*
Joined
·
11 Posts
perfect looks like you found ur problem, i have to do the same to mine when i get the thing back together, probably next year. great tip ranger
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,999 Posts
It's part of the spring clean up on all the cars in my family.
 

·
Registered
97eldoradoETC
Joined
·
134 Posts
Discussion Starter #11
well from the looks of things it was the first time it had been done because my friend said it was the worst he'd ever seen (and used to be a mechanic)
 

·
Registered
97eldoradoETC
Joined
·
134 Posts
Discussion Starter #12
yea well my friend said it was the worst he had ever seen and he was a mechanic
 

·
Registered
97eldoradoETC
Joined
·
134 Posts
Discussion Starter #13
ok so my problem has returned, a friend thinks its the throttle position sensor???? any ideas
 
1 - 13 of 13 Posts
Top