Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
2006 CTS-V
Joined
·
15 Posts
Discussion Starter #1
2006 CTS-V. All stock. After cleaning the Throttle body and MAF, now it idles at 1,750 RPM ONLY WHEN MOVING 3 MPH OR FASTER. (Come to a full stop and it settles down to 800 in about 25 seconds).

Checked for vac leaks. (none found)
Swapped TB (no change)
Swapped MAF (no change)
multiple battery disconnects to "reset" learning (no change)
Drove it 6 nights for full GM "Drive Cycles" starting with cold start. (no real change)

If you stop on a decline, let the idle settle to 800, put it in neutral and let off the brake, as soon as you get to 3 MPH, the RPM's begin to climb to 1,750.

I've searched multiple forums and read dozens of threads and still haven't found a solution posted.

At this point, I'm looking for someone who knows what this is and has the tools to fix it. This is so repeatable, I believe the right mechanic knows exactly what this is and how to fix it.

Located in Maryland. Looking for some help.

Thanks, Steve
 

·
Registered
2002 Eldorado Biarritz
Joined
·
451 Posts
There is a relearn procedure for the idle position. Turn the ignition off for at least 30 seconds. Turn the ignition on engine off for 60 seconds. Turn the ignition off for 30 seconds. Turn the ignition on and clear any DTCs. But, sometimes after cleaning the throttle body the throttle adaptives refuse to relearn. In that situation we reflash the ECM and force a fresh relearn. If it were in my shop we would have already reflashed it.
 
1 - 2 of 2 Posts
Top