Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Cadillac CTS
Joined
·
44 Posts
Discussion Starter #1
Hey guys,
I installed an hid kit onto my fogs about a month ago. All of a sudden, I have noticed that the hid fog light on the passenger side is now dimmer than the driver side fog. I have also noticed an ocassional flicker in that light too. My question is Could it possibly be that I have a defective bulb? or would it have anything to do with my fuses needing to be upgraded to a higher amount? Has anyone else encountered a similar issue to this one? Right now, im basically at the point in which I am just giong to take both lights out and return them to where I bought them (still under warrantee) But I would like to avoid going back under construction and unhooking everything.
 

·
Registered
05' CTS-V
Joined
·
3,718 Posts
swap your ballasts and see if the problem follows the ballast.....I've never seen a bulb go bad, but I guess it's possible....you can also try hardwiring it to the battery and see if that fixes it...if so, you'll have to run it off a relay.
 

·
Registered
2006 CTS 2.8L
Joined
·
2,471 Posts
I had my driver side HID bulb go out. Aftermarket kit. Got replacement, worked fine. It's happens.

Just got it back in today, actually.
 

·
Registered
2007 Cadillac CTS 3.6L Black, LOADED
Joined
·
2,424 Posts
Hey guys,
I installed an hid kit onto my fogs about a month ago. All of a sudden, I have noticed that the hid fog light on the passenger side is now dimmer than the driver side fog. I have also noticed an ocassional flicker in that light too. My question is Could it possibly be that I have a defective bulb? or would it have anything to do with my fuses needing to be upgraded to a higher amount? Has anyone else encountered a similar issue to this one? Right now, im basically at the point in which I am just giong to take both lights out and return them to where I bought them (still under warrantee) But I would like to avoid going back under construction and unhooking everything.
Well..... I had stock HIDs and replaced them with 10000k bulbs. I had my passenger side low beam bulb go out with in a week. Sent back both bulbs and had them replaced for free. They have been fine now for 6 weeks. My fogs have been great and problem free so far...

I have seen this posted now twice about the fuses... HID = High Intensity Discharge, but the name may be misleading. HIDs actually use LESS power then a halogen lamp. The ballasts just regulate the power (35 watts I believe).

If I were you I would try to narrow down the problem by just switching the passenger and driver side bulbs. See if the problem moves with the bulb. If it does, then the bulb is defective. If not, the ballast may be the problem. Take it from there.

Best of luck! :thumbsup:
 

·
Registered
Cadillac CTS
Joined
·
44 Posts
Discussion Starter #5
Thanks for the info guys. I'll go in and switch the bulbs and see what happens.
Thanks........
 

·
Registered
2005 CTS 3.6L, 2006 350Z, Ducati 996s
Joined
·
2,449 Posts
I have seen this posted now twice about the fuses... HID = High Intensity Discharge, but the name may be misleading. HIDs actually use LESS power then a halogen lamp. The ballasts just regulate the power (35 watts I believe).

Best of luck! :thumbsup:
Just to add to this, HID's draw about 3 x's the current on initial startup, but then drop to about 2/3's of a standard 55 watt halogen.
 

·
Registered
2003 CTS
Joined
·
43 Posts
I had to same problem with my headlights, aftermarket or course. It was the bulb. Replaced 2 times then switched vendors. I hope I don't have to drop the bumper again. I will I had never done this mod.
 
1 - 9 of 9 Posts
Top