Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1 (Edited)
first off my name is chris and i am the proud owner of a '91 sedan deville

i kinda found this forum in desperation....it goes a little something like this....

i have had a rough idle and check engine light on for about 2 months....and have drastically failed th eemissions test...gas mileage is around 10-12 in the city

just recently had a tune-up(everything) and replaced the converter(broken up inside ...probably due to running so rich)...the tech told me that the hard code was an 85 and that it directed him to clean the throttle body....which he did and cleared the code....only for it to reset a few minutes later....he told me to take it to the dealer

now...i am not a total newb....just out of practice so to speak...mainly an R&R guy....but i do have a good understanding of how things work

i just recently learned about the on board diagnostics..... and was planing on tackling the problem myself.....i was told the code was indictave of a possibly faulty TPS....which i had intentions of working on next week.....

last night i went to start the car....and nothing...just endless cranking....so i tried the onboard diagnostics...i am not sure what everything meant

1-E
2-EE
3-E85(as before)
4-E91(new...park/safety switch?)
then some numbers - .70?, 100?, .070?

i am really lost(and broke)....so all the help you can give me would be greatly appreciated

thanks

-chris

*edit*....i also wanted to add something...when i put the car in drive...there is this annoying clicking/popping sound...if i go from p to d to r to d again it will go away....i really have a feeling all of this is linked together seeing it all started at the same time....i could be wrong though
 

·
Registered
Joined
·
20 Posts
Discussion Starter #2
would a faulty prndl switch cause a no start condition?...i would imagine it would cause a no crank....but the engine cranks over fine
 

·
Registered
Joined
·
2,795 Posts
A faulty PRNDL switch could cause a no crank condition, but it would not keep the engine from starting if it cranks. Do you have a factory service manual? I would highly recommend getting one or a subscription to alldatadiy.com If you replace the TPS, you will need to adjust it, and I would try adjusting the one you have now first. the mechanic said he cleaned the throttle body.... open it wide open and take a look in there. See how bad the manifold is too. Make sure the throttle body closes completely and is not held open by anything.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
i cleared the codes...the 91 appeared to be a history code..and is not there anymore...the 85 reset almost immediatly...and the car is not even running?

i just purchased the subscription to alldata

on the no start condition....it seems the fuel pump is not powering up....at least i cannot here it run when i first turn the key to the 'on' position like i can hear on most other cars
 

·
Registered
Joined
·
2,795 Posts
Did you have the intake hose off yet to look at the throttle body? Check to make sure its not held open by anything first. If not, your TPS is either dead or maladjusted. With the PRNDL switch, if it was a history, sometimes that happens when the switch is "biased" to one side of the detent, and you might not have had it fully in that detent. Nothing to be concerned about.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
ok...the no-start was caused by a faulty ignition module

the 91 was a history code....once cleared it has not re-emerged

this is where i stand now

okay...i went thru the flowchart for e085...but that didn't fix the problem
the throttlebody is clean and the IAC and minimum idle is set....i had to go thru the procedure for letting the TPS relearn idle....idle is normal now
following the flowchart the properway...it didn't direct me to test or adjust the TPS...but it is an option....and the only one that i didn't pursue...so hopefully i will get to this after xmas

also....according to my data center...city mileage is inbetween 9.8 and 10.7 mpg
 

·
Registered
Joined
·
2,795 Posts
The thought is, if your TPS is well out of adjustment it could be causing the computer to shift the fuel table up to a richer mixture due to the false additional loading being signaled from the TPS.
 

·
Registered
Joined
·
5 Posts
The park/neutral safety switch assures that your car doesn't start in any other gears but neutral and drive..........Put your parking brake on and try to start your car in all gears........If it cranks up or attempts to crank in anything but neutral or drive then there may be a problem.........I just replaced one in my 93 Deville...........Ran me about 89 dollars from Advance Auto have not clue about the other code or why its not starting
 

·
Registered
Joined
·
20 Posts
Discussion Starter #9
DaveSmed said:
The thought is, if your TPS is well out of adjustment it could be causing the computer to shift the fuel table up to a richer mixture due to the false additional loading being signaled from the TPS.
which could possible be telling the ecm that the throttle plates are open to far ....hence the 85

thanks for all the help so far....merry ch...er uhh...happy holidays:canttalk: :D
 
1 - 9 of 9 Posts
About this Discussion
8 Replies
3 Participants
delvryboy
Top