Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11,009 Posts
Discussion Starter #1
Hey, it's been quite a while since I was last here, my computer stopped working fora week, so I built a new one (mmmmmm Athlon XP 2400+) and I have just been really busy, plus I love drinvg my DeVile, I drive it all the time, I put 2,400miles on her in less then a month heh.....

.....Anyway, wow, alot of things have changed, more ads, Sal got his Fleetwood, everyone gets along now....... Aug 23-24 I went to the Grand Am meet in Albany, that Sat. I was at Lebananon dragway, I got there late,so I was only able to race 2 times, my fastest time, which was my first run was a flat 16 at 83mph, I was disapointed a little, that puts me about even with a new Grand Am GT, I think that was due to me launching the car really bad, and maybe shutting down early (no finish line or anything) I had everything out of trunk (spare tire and jack, tool box etc....) only mods are a K&N drop in and I had almost a full tank (14gallons, tank holds 18) of gas with $10/bottle octane booster.....

....I think if I had only 3 gallons of gas, and launched the car well, I could do a 15.8 which was what I was hoping for, 16 just seems to low.....my reaction time sucked, like 1.4 or something, but it was my first time, and I didn' care about it, I waited until I saw the green light for a bit before I went, didn't want to red light, anyway, this is a pic a member of GAOC got:

lol, man I love this car, you just gotta love the ultra-musy suspension, look how high the nose is, and the rear fender is almost at the level of the white wall....... man that weekend was great, too bad we couldn't do something like that......

I dunno if you can view this thread or not, since noone is a mmber, but here is the whole rom that was created for the NY club meet, there are tons of pics and info and stuff, it was really cool.....

http://www.gaownersclub.com/forum/forumdisplay.php?s=&forumid=70
 

·
Registered
Joined
·
7,658 Posts
Hey Rick..... Welcome back!!

That just looks kinda weird..... The caddy going down a drag strip........ Hehe.......

16 seconds doesnt seem too bad....... Did it seem to be running really strong???
 

·
Registered
Joined
·
11,009 Posts
Discussion Starter #3
I dunno, mmy car is wierd, some days I barley hgit the gas and both tires spin others I can floor it from a stop and not get the tires to spin...that day is seemed prety baleneced, maybe running on the good side.......

I guess 16.0 for an 11 year old luxury car isn't too bad, but like I siad, my launching was pretty bad.

Yeah, ths first time i went against a '70 Chevelle SS 454 that was heavily modded, his 13.0 1/4 beat me just a tad....the second time I went agaisnt this guy in a '82 Toyota Starlet, these 2 guys are Spansih and built this thing up, it is RWD from the factory, and they are using the origanal 1.8L 4banger, it is pretty stipped though, but this thing was runing 12's all day (ran a 15.0 @ 78mph agaisnt me, something musta went wrong) anyway the anouncer was like "and next up we have a Toyota and a..................Cadillac?" lol, it was great

Hey, I wasn't any worse then the lady who raced her woody PT Crusier with a slick 18.1........oo bad it wasn't turbo.
 

·
Registered
Joined
·
7,658 Posts
Eww..... Wood grain...... Ill leave that for the dodge/chrysler minivans........ :D

Sounds like you had a great time...... Maybe we can get that little hesitation on yours fixed........ :)
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
2 Participants
elwesso
Top