Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
05 Stealth Gray V
Joined
·
1,567 Posts
Discussion Starter #1
Ok guys here is what they did to fix my oil temp problem. First off for those of you who don't know. When I drive with the air off I run about 250-260. If I turn the air on after driving for 15 or 20 min the temp goes up sometime to more then 320. Honestly I was a ways from home and it scare the $hit out of me. So i called my service advisor and he had me bring it in. When I got there I went onto the forum and showed him the post about the TSB and the doc numbers. (thanks to the guys here I had proof for them:thumbsup:) He gave me a rental and I was on my way. A couple of hours later he called and said come get your car. Of coarse they could not duplicate the problem because the will not drive the car around for a half hour. So I get there and he said they that ordered a new sensor for me. I go home and put into the garage and leave it alot. Then the next day I go out to wash it and find a huge (I mean a gash) taken out of my tire:mad:. Now I don't hit pot holes and when I go out I park a very long distance from where ever im going. It was bothering me because there is no way that I could have done it. Then I remember that my mechanic out tires on my old car about a year ago and when he was backing off the lift one of the arms caught the the rear tire and blew the hell out of it. Well I get the call tuesday that the part is in on my voice mail. I call him back and he says bring the car in at 8am tomorrow. I explain my problem about the tire and he says when you get here we will look at it. Well needless to say when he called and said that the car is almost done "we have to wait for your new tire to be put on and the tire guy is back up it will be ready later today. Well I get there and look a new tire and they fixed the sensor. They changed it and added a redundant ground. Now guess what problem fixed! So not only did they do right by the sensor they fixed a tire that they could have turned away. So kuddo's to Val Ward Cadillac on Fort Myers and a great big thank to Scott in service. :worship:

Gene
 

·
Registered
Joined
·
196 Posts
Your PM is full.

Ok. Got it. There is a IPC out for 2005MY

The document # is 1972141

Subject: Engine Oil Temperature Reads High Or False Warning Message - keywords DIC display gauge IPC #PIC4508 - (05/15/2007)

Models: 2005 Cadillac CTS-V

Condition/Concern:
Some customers may comment the engine oil temperature rises very quickly and remains high when they are not driving on long hills or performing aggressive maneuvers. In some cases the Oil Temperature Warning Message is displayed.


Hope this helps.
Did you give them this number? The procedure does not include replacing the sensor that's why I ask. The problem is with grounding. I think they should have run a redundant grounding wire.
 
1 - 2 of 2 Posts
Top