Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a 500 in my 55 Chevy Pick Up. Rebuilt it a few years ago and turned a 472 into a 500. Since then, I have found that we but the wrong pistons in. The engine came out of a 74 and was supposed to have 120 chamber heads, but had the smaller 72cc. Put on new larger chamber heads with bigger valves, stronger springs and new rocker set up. I also found that I had a flat lobe, so replaced the cam and lifters. I currently have a knocking noise that shows up when the engine is warm and get worse under load. Can't hear it while the engine is idling. I have thought that the timing was off for awhile, but shows right using the timing light. Right now I have it set at 10 deg. BTDC. It just doesn't seem to be right. The cam was installed straight up. I am pulling what hair I have left out. Love the engine, but would like it to run and perform like I know it can. It also has and Edlebrock intake, MSD ignition, but has stock exhaust, have headers, but can't get them to fit right now.

Help, is there an expert in Northern California? Or does anyone out there have any ideas on the two problems (knock and timing), maybe they are caused by the same thing?
 

·
Registered
1995 Sedan De Ville (4.9 L)
Joined
·
581 Posts
Wrong piston etc -> higher compression -> knocking
Am I correct?

Also why do you think 10 deg. BTDC is not right, any
reason you think it is wrong??
 

·
Banned
1995 ETC, 75 Deville, Cad500 powered 73 Apollo, 94 Mark VIII
Joined
·
7,971 Posts
Well improper timing can result in knocking, but so can too high compression. Have you checked the compression?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I corrected the high compression problem when I put the new set of heads on. Before the compression was 190-195, after putting on the new 120 cc heads it dropped to 130-135. The reason I think that the timing is off or something is still wrong is because of rough idle and a little run on when I shut it off. I was wondering if I had the wrong pointer & pulley when I swapped in the new 500 crank (it was originally a 472), but Chris over at Cad Company said it didn't matter. As long as the pointer and pulley came from the same engine I should be OK. I am going to double check and find TDC using the method of rotating the engine both directions with a bolt in the spark plug hole as a stop and splitting the difference. The funny part and what is confusing me is that it only knocks when the engine warm and only sometimes. I drove it 50 miles this morning and heard nothing. Last night going home (up hill) it knocked on and off all the way home. I am wondering if I don't have a lifter or cam problem again. I also have a water pump that is making a whine when warm, maybe this is my knock. Have a new one on the way. I hate these kind of problems and it seems that this engine has been full of them.

This is a great forum, I haven't found to many people who know much of anything about Cads.
 

·
Registered
1991 Cadillac Brougham D'Elegance 5.7 Litre, 1994 DeVille
Joined
·
6,796 Posts
Turn your timing back a bit and see if it cuts down the pinging at all. What's the octane rating of the gas you're using?
 

·
Registered
1995 Sedan De Ville (4.9 L)
Joined
·
581 Posts
I am not sure if improper timing makes idle rough,
unless it is wayyyy off and if so you will know from
lacking a lot of power.

Well, how did you tune the amount of fuel put in
the engine?? Since your engine is different from
the original configuration, you may need slightly
different pattern of fuel deliverly as you open the
throttle.

Anyway, seems like your knocking is very slight.
I think making mixture richer or retarding the timing
a couple of degree would solve the problem...

Good luck!
 
1 - 6 of 6 Posts
Top