Cadillac Owners Forum banner

1 - 20 of 25 Posts
T

·
Guest
Joined
·
0 Posts
Discussion Starter #1
My car keeps cutting off! Check engine light is on and it said it was the Maf so I put a new one in. It's like it's not getting fuel. It will go from 2K RPM down to 500RPM and cut off. When I start it back up it's missing bad, but then it will stop. I have no loss of HP! It is worse when I turn the A/C on and I feel like I lose 75HP with the A/C on. When I turn it off it rattle bad but may be my header. It also seems if it's worse going up a hill. I still have stock fuel pump and injectors with my heads and cam. As long as I leave the A/C off it almost never does it.:bighead:
 

·
Registered
2004 CTSV
Joined
·
1,133 Posts
Have you put a meter on to check all codes?
If you don't have a meter, you might be able to get OnStar to give them to you. The OnStar rep will tell you to go to your dealer but keep asking for the codes that they see.

I hope it's something simple
 

·
See you in the funny papers
04 CTS-V, 05 STS, 07 SRX- All sold :(
Joined
·
26,239 Posts
Check your fuel filter, or if it hasn't been changed in a while just do it.

I'd also make sure you haven't had a plug or wire come loose, or have a cracked plug.

Start with basics: Fuel, Air, Spark.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #4
I will check all that today! Thanks guys.
That was the only code!
 

·
Registered
Joined
·
1,928 Posts
Check compression? Plugs? - are you misfiring? Do you hear a leak/ping or a rattle? - if so check header gaskets?

Your tune?
what are you idleing at without air on? and with?

Does it feel like it bogs while gasing it especially up hill?
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #7
Chef I do hear a ping/rattle. My car always had valvetrain noise but now it's louder. I idle at 1 K with no A/C and 900 with A/C. Yes it will bog up hill but only with A/C on. I just fixed this thing 2 months ago for a bent exhaust valve and was charged 3,600. Never been correct since. I thought pushrods were to long but they said no.
 

·
See you in the funny papers
04 CTS-V, 05 STS, 07 SRX- All sold :(
Joined
·
26,239 Posts
^ Ah so.......it all becomes clear now. Unfortunately, I do not think your problem lies externally. You need to contact whoever did your valve job.
 

·
Registered
04CTSVsc
Joined
·
854 Posts
Chef I do hear a ping/rattle. My car always had valvetrain noise but now it's louder. I idle at 1 K with no A/C and 900 with A/C. Yes it will bog up hill but only with A/C on. I just fixed this thing 2 months ago for a bent exhaust valve and was charged 3,600. Never been correct since. I thought pushrods were to long but they said no.
uhh-oh.
 

·
Registered
Joined
·
177 Posts
having a push rod that is too long will only leave that valve open a little longer then it should be, not a huge deal. You mention that the valve train is noisy, are you using dual springs? When you put the heads and cam in did you do a push rod length check? Does the cam have a small base circle? Trying to figure out what the A/C being on would have to do with this? What tunning software are you using and what are your logs looking like when this is going on? Just need some more info here to help.
 

·
Registered
05 maggied CTS-V, 2017 NSX Whoo Hoo!
Joined
·
8,810 Posts
having a push rod that is too long will only leave that valve open a little longer then it should be, not a huge deal. You mention that the valve train is noisy, are you using dual springs? When you put the heads and cam in did you do a push rod length check? Does the cam have a small base circle? Trying to figure out what the A/C being on would have to do with this? What tunning software are you using and what are your logs looking like when this is going on? Just need some more info here to help.
\
NOT A BIG DEAL?

Are you kidding?

You can bend a valve (don't ask).

I get suspicious when you already bent one.

Welcome to mod hell, paying your dues.

Since your problems started with your heads/cam swap I would expect that is where things went wrong.

Also, the valve train noise is a red flag.

I had pushrods rubbing on the holes even though I didn't change the ratio, but the rockers (Comp #1500 system) changed that position and the pushrod length.
 

·
Registered
Joined
·
177 Posts
Assuming that the heads are not decked and the gasket has not changed there should not be a push rod problem, but I still wonder why that would not be checked just to make sure of that. Im talking a pushrod that is off by one size, like 7.40 to 7.45. Leaving a valve open for a little longer then it should be will not hurt anything, been there and done it on the dyno. If he is making valve to piston contact then the problems are HUGE and they did a poor job with geometry. How long have you had the heads/cam on the car? What C/R are you running?

BTW your right about valve train noise being an issue but at the same time if your running a X lobe cam and dual springs its going to be noisy. The best way to get rid of this is run the Caddy race lifter and know what your doing when you preload them with a PUSHROD lenght checker. But with out hearing the motor who know's what noisy is to him.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #17
Ok well we did a compression test and leak down test and it's ok. The codes were lean in bank one and the MAF code. We cleared the code and it has not cut off yet. I have dual springs and we did take valve covers off and they were fine and so were the push rods. He thinks it was never tuned again after they milled the heads. Not sure what compression ratio is now that the heads were milled. Thinks we can fix it with a tune. I was told most of the ticking I hear is my throw out bearing in the clutch. They are installing my new clutch and flywheel in the morning and they will look at the bearing and replace if needed. The car has always had some valve train noise even before I did the heads and cam. So how much reduction in nose will the caddy race lifter provide?cost?were do I get them?
When I bent an exhaust valve it was not me but the guys at NTB who did it on a test drive and missed shifted while spraying nitrous.
 

·
Registered
2015 BMUU 335i MSport, 2006 STS-V--2005 CTS-V ( traded in)
Joined
·
25,514 Posts
When I bent an exhaust valve it was not me but the guys at NTB who did it on a test drive and missed shifted while spraying nitrous.

OMG :eek:

Well at least at the meet tomorrow the shop owner is supposed to be offering deals on tunes (as I read things). So maybe you can get it tuned up and a slightly reduced cost ?
 

·
Registered
Joined
·
177 Posts
Well on my 408 the caddy lifters made a huge difference for me. With my X-er cam (very steep lobe) and Patriot dual springs, this combo is very loud. There are ways of checking the push rod length with a the tool but I would have them checked unless you are trusting of whoever installed the heads? The reason I say this is if the pushrods are not perfect and the preload is not right it will be noisy no matter what. I would call John at SDPC and get a set of the Caddy lifters, ask them for the preload. Here is your part number 88958689 $227

I realize that Heavymetals thinks Im just throwing shit out here, but Im just trying to help the guy out. I don't know if I buy the tune problem answer, but hey lets see what they come up with. What software are you using? Good luck man
 
1 - 20 of 25 Posts
Top