Cadillac Owners Forum banner

1 - 20 of 21 Posts

·
Registered
Cadillac
Joined
·
38 Posts
Discussion Starter #1
wHAT'S UP GUYS....THE OTHER DAY I WAS DRIVING MY CAR DOWN A NICE SMOOTH ROAD WHEN ALL OF A SUDDEN I GOT HIT WITH ALL OF THIS AT THE SAME TIME...Help!!!! SERVICE STABILITY SYSTEM & SERVICE BRAKE ASSIST ALONG WITH THE TRACTION ENGAGE FOR ANY LITTLE BUMP ON THE ROAD!!!!!!! wHAT DOES THIS MEAN AND HOW CAN I FIX IT.....HAS ANYONE ELSE HAD THE SAME PROBLEM???? I ALSO FELT MY BRAKES STUTTER A LITTLE WHEN I WAS COMING TO A STOP???? ANY ADVICE WOULD HELP PLEASE????? THANKS!:banghead:
 

·
Premium Member
2006 STS V8 AWD, '95 Ford Ranger
Joined
·
28,973 Posts
Your car has completely blown up. It will cost thousands to repair. The damage is so pervasive that your computer has locked the CAPS key. It also purged the part of your post where you told us the year, model, and milage of your car.
 

·
Registered
2005 CTS 3.6 Sport Lux
Joined
·
61 Posts
Hey sam whats going on? Did you take it to the dealer yet? I know a guy in Williamson Cadillac that could prob help you out, your still under warranty right? Give me a call.
 

·
Registered
'04 CTS, '79 Coupe DeVille, '78 Sedan De Ville, '77 Firebird
Joined
·
1,020 Posts
my service brake assist light comes on when i do prolonged burn outs and on particulary loud bass from the 2 15" subs in the trunk. dealer usually tells me that he notices a rpm spike right before it happens
 

·
Registered
Cadillac
Joined
·
30 Posts
I think your friendly Cadillac dealer is the guy you need to seek out. Any kind of issues like you speak of typically require a diagnosis from a certified technician with the proper tools.:bonkers:
 

·
Registered
2003 Cadillac CTS Luxury Sport
Joined
·
516 Posts
I had the SERVICE STABILITY SYSTEM message before, and it was the steering position sensor. But I never had the SERVICE BRAKE ASSIST message. Good luck, let us know.
 

·
Registered
Cadillac
Joined
·
38 Posts
Discussion Starter #10
I wll take it to Cadillac and get it diagnosed...I believe it's the positioning sensor and I will get it checked out...Thanks for all your input...
 

·
Registered
'16 VSport (wife's), '10 Escalade, '97 & '02 SS Camaro's, '15 Silverado LTZ
Joined
·
1,132 Posts
I wll take it to Cadillac and get it diagnosed...I believe it's the positioning sensor and I will get it checked out...Thanks for all your input...
Please post back and let us know what the problem was. My wifes '97 ETC w/ 56k is doing the same thing. I keep hearing it's probably the steering position sensor.
 

·
Registered
CTS
Joined
·
1 Posts
I had the issue with the "Service Stability System" message coming on randomly, & some tugging at steering wheel with my '05 CTS. I had the Steering Postion Sensor replaced ($250) and low and behold-- the "Service Stability System" message came back on a couple of days later. And on top of that, now I am getting the thing with my brakes that feels like the anti-lock system is kicking in, almost put me in tail spin this morning. I am taking it back to dealership tomorrow -- we'll see what they try to fix this time. I'll keep you posted.
 

·
Registered
'16 VSport (wife's), '10 Escalade, '97 & '02 SS Camaro's, '15 Silverado LTZ
Joined
·
1,132 Posts
I had the issue with the "Service Stability System" message coming on randomly, & some tugging at steering wheel with my '05 CTS. I had the Steering Postion Sensor replaced ($250) and low and behold-- the "Service Stability System" message came back on a couple of days later. And on top of that, now I am getting the thing with my brakes that feels like the anti-lock system is kicking in, almost put me in tail spin this morning. I am taking it back to dealership tomorrow -- we'll see what they try to fix this time. I'll keep you posted.
I had the same issues and once the SPS was replaced everything is normal. Kinda makes wonder if it was defective new, or not installed correctly or, they pulled the old "let's don't and say we did" trick. I would hope a stealer err... dealership wouldn't stoop that low.
 

·
Registered
Joined
·
5,630 Posts
Just an observation. It seems that when the DIC says 'Service Stability System' only, then its the steering position sensor. But if the DIC also says 'service brake assist', then its not the steering position sensor. I know I had the SPS replaced, yet both msgs came up on the screen again the same day and continued for a couple weeks until the weather warmed up. I actually havent had it fixed, as it 'fixed' itself. Take that for what you will. But I can say that with both msgs shown, the SPS replacement didnt fix it.
 

·
Registered
They should make a new model name for mine but I guess a CTS
Joined
·
271 Posts
Ihad the service brake assist problem and my brake assist relay on the drivers side fuse box under the rear seat had gone bad
 

·
Registered
2005 CTS
Joined
·
3 Posts
well guys i have a CTS 05 and i had pretty much the same proble it´s started every time that i pase thru a bump and now i have the brake problem that almost make me spin so let me know if some one got fix this problem,
 

·
Registered
Cadillac
Joined
·
74 Posts
just searched this post, AFTER i posted mine lol did anyone ever figure out the problem b/c i already almost lost my front end multiple times from the "anti-lock brake pulse" preventing me from stopping. please help, WINTER IS COMMING!! thanks
 

·
Registered
Cadillac '05 CTS
Joined
·
17 Posts
I would love to get some feedback on this if anyone has had the same problem and had it diagnosed and fixed correctly. Also any cost information would be helpful as warranty is up on my '05 3.6 with 75,000. It almost feels like payback as i had just got back from a nice little vacation in mexico, first time i sat in my car and turned it on the "service stabilty system" popped up, followed by "service brake assist" which was followed again by "service stability system" Heaven forbid a problem arise just when i'm on cloud 9.

I've driven the car a couple times and it doesnt feel like there is a problem. I second the above comments though, its amost winter (already snowed once) and i would love to get it taken care of, but dont want to get raped by the stealer, i mean (dealer) and if i can go in with any information form you guys that would be great. Thanks
 

·
Registered
SRX
Joined
·
1 Posts
first time i sat in my car and turned it on the "service stabilty system" popped up, followed by "service brake assist" which was followed again by "service stability system"
I have this exact problem on an 04 SRX, any chance you had this diagnosed and fixed? Any help is appreciated.
Thanks!
 
1 - 20 of 21 Posts
Top