Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hello everyone! Hoping someone out there can help me.

When I turn the key in the ignition of my 1990 Cadillac Sedan Deville, I hear a very sharp screeching noise for a few seconds. The noise sounded to be coming from the right side of the car, under the hood. When I lifted the hood, I noticed an unusual sound coming from the area around the alternator. It was that same sort of screeching but much more dull. I just replaced the alternator and serpentine belt about 2 months ago but am wondering if the problem could be related to that. Any ideas? Thanks so much!
 

·
Registered
Joined
·
238 Posts
i would get one of those mechanic stethascopes and poke around. did u replace the alt with an acdelco? i've heard bad things about using non acdelco alts
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
I'm not sure what type it is but it's the second replacement alternator. After replacing the first one, the charging light came on and the alternator froze up. Replaced it with another new one and so far so good. Except for this new noise. Thank you for your suggestion.
 

·
Registered
Joined
·
238 Posts
no prob. i would deff check out the manuf. sounds like u may have a non acdelco. the 1st one u replaced was that 2 months ago or the 2nd one?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
As far as I can tell, yes. I had the pulleys checked the last time the alternator was replaced. I guess it's possible that one has gone bad. I will check the belt and pulleys int he morning. I appreciate your help.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
Well the first time I replaced the alternator was about 2 mths ago. It lasted about 5 days and then froze up. The second was replaced the next day. So I've had this second one in and running for approx. 2 months now. I will check the manufacturer int he morning. Again, thank you.
 

·
Registered
Joined
·
238 Posts
also u may want to get ur battery tested and charged to be safe. bad alts can do bad thangs to batteries. also if its the belt squeeling u could try some warm soapy water (dish soap works well). with tha car running spill some (not too much) very carefully on the belly of the belt and it will quite tha thang on up. works like a charm. does tha sound happen constantly. a squeeling belt will usually go away will acceleration.
 
1 - 8 of 8 Posts
Top