Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi folks,

New member here, in urgent need of some advice. I have a 93 Eldorado that unfortunately developed a transmission or computer problem...while I was down in Southern California visiting my dear old Mom.

The 400 mile trip down was fine, although the "Check engine soon" light did come on briefly. During my last day there however, the car suddenly decided that it didn't like overdrive. I was accellerating onto the freeway when all of a sudden the revs jumped as if the tranny had disengaged. I slowed down a bit and realized that the tranny *was* engaged, but in what felt like 2nd gear. Reaching surface streets again proved this to be the case...the car operates nicely until it hit's 3rd gear, then jumps back down to 2nd and stays there.

Pardon me while I weep for a moment...

So, unable to drive the car home *or* to the nearest Caddy dealership (about 40 miles away), I took it to a local mechanic. He checked the error codes and nothing showed up immediately. Having to work the next day, I left the car with him for further diagnostics and rented a car to get home. That was three weeks ago...and he has yet to find the problem.

So...any thoughts? (pleeease) I miss driving my Caddy, and have been stuck with either my motorcycle or my girlfriends Honda with the broken drivers seat. (I let her drive my truck because of the broken seat, which we can't find a replacement for, and oh my back hurts...) :p If I can make some suggestions maybe this guy can figure it out. He's honest (my Mom's mechanic for years) but it might be over his head. (?)

I thank you for your help in advance!

Regards,
Pete
Silicon Valley
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
p_rabbitt said:
Hi folks,

New member here, in urgent need of some advice. I have a 93 Eldorado that unfortunately developed a transmission or computer problem... (snipped)
Me again. I forgot to add that the darn car only has 55K miles on it.

Back to pouting about my car now.

Pete
 

·
...Reloaded
Joined
·
1,698 Posts
Hey Pete - it sounds like it *could* be a bad solenoid. First things to do are to check for codes and check the trans fluid for level, color, and odor. Let us know what you find...

Look here for instructions on accessing the codes.
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
3 Participants
filippmiler
Top