Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
378 Posts
Discussion Starter #1
Hey all,

Pulled into the garage tonight, shut down, heater fan still on..hmmm undid the negative cable waited about 30 min hooked it back up..still the fan runs...so I then unhooked the blower module cable..shut off....hooked it back up and started car, now no fan...Is it the module or could it be something else...trying to limit the troubleshooting to a bare minimum when anypart is a fortune.

Now this past summer there was an issue of the fan would come on and off when trying to run the air or heat and then it just "fixed itself" one day, been good now for 6 months :worship: (Thought it was my reward for rescuing it from very bad abusive and neglectful owners) :cookoo:

BTW; 93 STS 119,000
Thanks for the help
 

·
Registered
Joined
·
174 Posts
Hi Realtor1,

It is almost positive it is the module, judging by your description of it staying running with the car off. It is very common...

I have an extra used one I pulled off a 93 eldorado in a boneyard last year for $15. It didn't fix my problem, mine needed a new blower motor. Mine just plain never ran at all when I first bought it, and I figured it was an inexpensive thing to try before going with a new blower motor.

If you want it, I would let you have it for $15. I would throw in the shipping. Let me know...

Dave
 

·
Registered
Joined
·
378 Posts
Discussion Starter #4
Dave, Go figure I bought one the morning after it broke, before I got your post..BUT since they seem to be an item that goes out often, I would still be interested in picking it up from you for 15.00.

Extra parts in my book is like extra money ...a good thing :)

Let me know how you want me to pay, PAYPAL or send check.

Thanks
 

·
Registered
Joined
·
174 Posts
Wow, you didn't waste any time replacing that, but when it is cold you need heat! Glad you got her fixed. ;)

Another strange coincidence... I was just down in Florence, KY last weekend! Went down to pick up a 95 Grand Am for my son. 430 mi. but worth the trip! :D

Sorry , don't have paypal set-up. Just send me a check for $15 and your recieving address, that's fine. Sending you a private message with my email and home address. Let me know if you need anything else! :coolgleam
 

·
Registered
Joined
·
378 Posts
Discussion Starter #6
sprucegoose said:
Wow, you didn't waste any time replacing that, but when it is cold you need heat! Glad you got her fixed. ;)

Another strange coincidence... I was just down in Florence, KY last weekend! Went down to pick up a 95 Grand Am for my son. 430 mi. but worth the trip! :D

Sorry , don't have paypal set-up. Just send me a check for $15 and your recieving address, that's fine. Sending you a private message with my email and home address. Let me know if you need anything else! :coolgleam

Yeah I couldnt go long without the heat...even though its not bad here like it is from my home state (Maine) it went out at 8:00pm had the part next morning by 10:00am..Wish I had been a bit slower, would hahve saved a ton but oh well...got a spare now...Mailing address is on check, will be out on monday...Thanks again!
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
3 Participants
Realtor1
Top