Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
2008 Escalade
Joined
·
1 Posts
Discussion Starter #1
I have a 2008 Escalade with no power whatsoever. nothing in the Escalade works not the remote lights nothing. the truck won't even a lock with the remote or with the button inside the truck. the truck won't even turn on nothing works but the AC and the navigation. last night I was sitting in the truck with the stereo on and the key out of the ignition. I open the driver's door to open the passenger door got back into the driver seat and nothing would turn on. no lights come on nothing but the AC and navigatio. I had to get it towed to my house last night please help. I think it has something to do with the anti theft system.
 

·
Registered
2018 XT5 Platinum, 2014 S550
Joined
·
1,653 Posts
Try disconnecting the battery for 10 min, then re-connect. Also, make sure battery is good.
 

·
Registered
2008 ESV, 2004 Escalade
Joined
·
165 Posts
Is it the original battery? I've seen some weird things happen to these trucks with weak batteries. If not, first thing I would do is turn off the AC and the radio, then disconnect the battery. Touch the positive and negative cables together and reinstall the battery.
 

·
Registered
A red 2007 escalade base and a orange 2004 lamborghini galla
Joined
·
167 Posts
Be careful though because if your not careful you can fry the electronics/computer/ and all sorts of electrical parts of the truck if your not carefull
 

·
Registered
07 Escalade, 01 DEVILLE,'68 SEDAN DEVILLE (CTS SOLD)
Joined
·
31 Posts
I took the battery out of my 2007 escalade to jump start another car and put the dead battery in the escalade to the same results your describing. Even after the battery was fully recharged nothing in the truck worked. The dealer said i fried the BCM (body control module).
 

·
Registered
2007 Escalade ESV
Joined
·
268 Posts
Your REAL key is being detected as the spare key that will only unlock the door physically and not turn anything on.
You need to check your key/ignition.
Maybe that is your issue. Not sure.


As for your ac and navigation turning on. I honestly don't know.

Or just a simple dead battery. Lol
 
1 - 7 of 7 Posts
Top