Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi all-

I just bought a 97 STS. The washers won't shut off. I replaced the switch and the delay cover on the motor...still have continuos washer. All data says try the rain sensor module next. Anybody agree or have another solution.

Also the dash lamps for the 4 gauge cluster is out. Every other lamp is fine. Does anyone know which fuse feeds those lamps?

Thanks.

:)
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
Have you checked your codes yet???

I think maybe a relay is somehow stuck open.....

So is it the windshield washeres or wipers that are broken.....?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
It is the washer that won't shut down once the wipers are turned on. I'm going through washer fluid like Grant took Richmond.


:D
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
I bet the wiper switch is goofy, and something is getting stuck (ie the switch or a relay).....

Without a FSM this could be very hard to determine, unless someone else here has had the same problem.....
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
elwesso said:
I bet the wiper switch is goofy, and something is getting stuck (ie the switch or a relay).....

Without a FSM this could be very hard to determine, unless someone else here has had the same problem.....
I 'rebooted' the computer - actually pulled all fuses to check them and the wipers now work fine. :D

The gauge lites are powered by two 2 amp fues under the driver knee panel. One was not making a good contact. Gauge lamps are working again. :yup:
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
w00t!!!! I love cars that fix themselves, or fixes that are free!!!!

What you did is common practice for electrical problems.... however most people just unplug the battery overnight.... That seems to work very well...... Ive fixed numerous things with that!
 
1 - 6 of 6 Posts
Top