Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Lets start a new thread on this subject huh? We have talked about my 4.9 having a rough idle in the DeVille Section under :94 DeVille Idles Rough" and a little more in the Pushrod section under " Car Problems".

Anyway, to do a short recap.....

Idles rough w/out a/c on, in and out of gear, smooths out when load is applied. The TB has been cleaned, EGR replaced and passages cleaned, vac lines replaced, new plugs, wires, cap and rotor, PCV Valve, air and fuel filter.

I have done the power balance test, it passed. Today I did the Injector Flow, fuel Pressure and OHM's test. This is what I got. (Oh yeah...When I tossed the FP Tester in the car on the way home she was idling just smooth as the day she was new. Too bad it didn't last too long.)

KOEO: Fuel Press 40 PSI

Pressure drop each inj:

1. 22#
2. 22#
3. 22#
4. 20#
5. 20#
6. 22#
7. 22#
8. 20#

OHMs Test

1. 12.8
2. 13.1
3. 12.7
4. 12.8
5. 12.6
6. 12.7
7. 12.6
8. 12.9

Now the questions are......
1. The manual says: "Replace injector(s) that had a pressure drop not within 2psi of each other." ...would this cause it, or is this really acceptable?

2. OHMS Test. Manual says 8-25 OHMS. To me that is a pretty broad range. The only two I question are Injs 2 and 8. The rest seem to be within each other +/- one tenth. What do you think?

3. The next test is a Voltage Drop test which requires Essential tool J-39021. I don't have this tool and don't know what it does. But they want me to see if any Inj has a voltage drop of more than 9.5 volts and replace those Injs.

So now what do I do? I'll appreciate any help I can get.

Thanks,
Jason
 

·
Registered
Joined
·
47 Posts
ga_caddy said:
Lets start a new thread on this subject huh? We have talked about my 4.9 having a rough idle in the DeVille Section under :94 DeVille Idles Rough" and a little more in the Pushrod section under " Car Problems".

Anyway, to do a short recap.....

Idles rough w/out a/c on, in and out of gear, smooths out when load is applied. The TB has been cleaned, EGR replaced and passages cleaned, vac lines replaced, new plugs, wires, cap and rotor, PCV Valve, air and fuel filter.

I have done the power balance test, it passed. Today I did the Injector Flow, fuel Pressure and OHM's test. This is what I got. (Oh yeah...When I tossed the FP Tester in the car on the way home she was idling just smooth as the day she was new. Too bad it didn't last too long.)

KOEO: Fuel Press 40 PSI

Pressure drop each inj:

1. 22#
2. 22#
3. 22#
4. 20#
5. 20#
6. 22#
7. 22#
8. 20#

OHMs Test

1. 12.8
2. 13.1
3. 12.7
4. 12.8
5. 12.6
6. 12.7
7. 12.6
8. 12.9

Now the questions are......
1. The manual says: "Replace injector(s) that had a pressure drop not within 2psi of each other." ...would this cause it, or is this really acceptable?

2. OHMS Test. Manual says 8-25 OHMS. To me that is a pretty broad range. The only two I question are Injs 2 and 8. The rest seem to be within each other +/- one tenth. What do you think?

3. The next test is a Voltage Drop test which requires Essential tool J-39021. I don't have this tool and don't know what it does. But they want me to see if any Inj has a voltage drop of more than 9.5 volts and replace those Injs.

So now what do I do? I'll appreciate any help I can get.

Thanks,
Jason
All the test done look good, volt. drop I dont think you need to do. Common problem with these that no one will think about that I see often is a broken frt. motor mount and/ or trans. mount. You will not believe how rough some 4.9s get with this condotion. It something to look at. Net diag. is very diff.
 
1 - 2 of 2 Posts
About this Discussion
1 Reply
2 Participants
cadfan
Top