Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Morning all,

This morning my daughter left the house after letting the car warm for 3-5 min, got less then a 1/4 mi turned on the heater, all dash electrical, stereo, climate control went dark except with check engine light and engine cut off.
She was able to re-start it and (after calling me) turned around and returned home. Engine is NOT hot, oil is OK. Checked several of the fuses all apear to be good (visually). Car was inspected in August (before someone asks) and all emissions was far below limits.

What on gods green earth could have happened to it? Any suggestions on what I may check?

thanks,

Adriano
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,184 Posts
How old is the battery? How about the battery cables? Any corrosion on the contacts or under the insulation?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Battery is 6 mo old, (not sure why you asked, for the car starts and runs fine). Battery cables and connections A OK.

Thanks

Adriano
 

·
Registered
88 Sedan Deville, 89 Eldorado, 11 SRX, 18 CT6
Joined
·
130 Posts
ok... this may also help... turn ign to ON but not start... hold OFF and WARMER on climate control.. read off (and post here) all codes displayed in the FUEL Guage.... E, EE, F, FF. 70 means end / no codes / next menu)

have you had alternator checked.... mileage on car... i own an 88 deville, and have about all the info you'd ever need as far as manuals and diagnostics. hit me up [email protected] ill try to help out as best i can. was there a burning smell? anything else that could possibly relate...
 
1 - 5 of 5 Posts
Top