Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I just did 04 nav install on my 05 cts, It worked perfect 4 about a week!! :) WELL atleast until last night. It started up, the crest came on like normal, put in reverse and backed out. Then BLAMO!! Blank screen!! Radio still plays but unable to switch source from steering wheel.:banghead: I was messing around and found the diagnostic screen about an hour before, but I didnt think I actually did anything. (I was trying to play a burned dvd) I even pulled it out and checked all connections. None of the buttons work on the nav but I can insert and eject cd's, Dvd wont accept any. I bought from EBAY and it was straight plug and play. NO WARRANTY!!! :annoyed: Any idea's??? :hmm: :hmm: :hmm: Can I even take to dealer and have them diagnotic it??
 

·
Registered
'02 ETC CE, '04 CTS-V, '04 XLR, '13 XTS Platinum
Joined
·
2,654 Posts
Caveat Emptor when buying expensive electronics on eBay. Sure, the dealer can diagnose the problem, and if you're REAL lucky, it might be something ridiculously easy or cheap to repair. Worst case, your display is FUBAR and you get to pay full price for a warrantied GM part. Good luck!
CCC
 

·
Registered
04 CTS Lux Sport
Joined
·
33 Posts
I did somethign similar to my 04 CTS NAV while monkeying around with the diagnostic menu. Dealer had to replace the entire unit, fortunately under warranty. Good luck.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4 (Edited)
HOLY COW!! I would believe it, if it didnt happen to me. I took the car down to the dealer to read some codes or something and they just ended up replacing it!! They tested it and said the "radio was faulty". So the question is, Do I now have a "warrantied" nav unit??? I was just assuming they would tell me some outrageous amount for the fix. I have the an extended warranty, but didnt think that would matter.
I was sweating there for a while thinking I was out of the GRAND I paid for the unit. Im just thanking my lucking stars that I got out of that problem.
 

·
Registered
Joined
·
466 Posts
brokencts said:
HOLY COW!! I would believe it, if it didnt happen to me. I took the car down to the dealer to read some codes or something and they just ended up replacing it!! They tested it and said the "radio was faulty". So the question is, Do I now have a "warrantied" nav unit??? I was just assuming they would tell me some outrageous amount for the fix. I have the an extended warranty, but didnt think that would matter.
I was sweating there for a while thinking I was out of the GRAND I paid for the unit. Im just thanking my lucking stars that I got out of that problem.
:hmm: WOW, what a deal. Go back Monday, tell them you paid for a CTS-V and you think you're missing a few parts. While you're there, do a little "back slapping" and let them know what a great service department they have.
 

·
Registered
Joined
·
2 Posts
1 question no related to blank screen......you put a 2004 Nav radio in a 2005 you said plug And play explain.......did you have too re wire or anything....thats amazing.
 
1 - 6 of 6 Posts
Top