Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi . . . . I just joined a couple minutes ago and this looks like a nice site. I've been looking for a resource like this for a while. I have a 93 Deville that's our extra vehicle and my baby, a 97 Seville SLS.

The reason I happened upon cadillacforums is that the heater/ac fan quit last week. I took it into my general mechanic and he said there wasn't anything wrong with the fan but could be something with the climate control system. He can't work on it but he mentioned a "module" or computer or something. Can anyone shed some light on this for me and tell me what I'm in for?

Thanks,

Jeff
 

·
Registered
just one
Joined
·
1,386 Posts
jbrown said:
Hi . . . . I just joined a couple minutes ago and this looks like a nice site. I've been looking for a resource like this for a while. I have a 93 Deville that's our extra vehicle and my baby, a 97 Seville SLS.

The reason I happened upon cadillacforums is that the heater/ac fan quit last week. I took it into my general mechanic and he said there wasn't anything wrong with the fan but could be something with the climate control system. He can't work on it but he mentioned a "module" or computer or something. Can anyone shed some light on this for me and tell me what I'm in for?

Thanks,

Jeff
Jeff, welcome to the Caddy forums. It could be a wiring problem, Check your codes... NICE CAR, got the same one.
 

·
I'm a Cadillac Fanatic!
Joined
·
9,575 Posts
Welcome aboard, Jeff.. And thanks for signing up! It sounds like your problem may be best addressed in the Electronical Technical section. Try posting this there. Okay? I bet you'll get a quicker answer by doing so...
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
Howdy!!! And welcome aboard!

Lets keep the technical discussion in the tehnical area!!!
 

·
Registered
Joined
·
125 Posts
Welcome. Nice to have you with us. I have the same car in Diamond. Hope you get it fixed.
 
1 - 9 of 9 Posts
Top