Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
338 Posts
Discussion Starter #1
03 escalade like the title says.
Not a good thing in the summer. Came on more than 30 times in 30 miles one day was gonna crash if i kept checking the display.
Unhooked the master connector under the seat to get home and did some reserch couldnt find a better fix than the seat unplugged.
Wasnt happy with the seat non adjustable and the airbag light comes on.
So I found the six wires black taped together that come from the seat back underneath the seat and unplugged that connector. I then plugged in the master connector and everything in the seat except heat works and the airbag light is off
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Does the control lights kick on even with the seat module unplugged?
If so then the switch module is bad if not then the seat module is bad as it controls the seat warmer
 

·
Registered
Joined
·
338 Posts
Discussion Starter #4
the cadillac man said:
Does the control lights kick on even with the seat module unplugged? If so then the switch module is bad if not then the seat module is bad as it controls the seat warmer
No lights came on pushing the heat button with the main connecter under the seat disconnected.
Now with that plugged back in but the 6 wire heat element connecter(ibelieve) unplugged the heat indicator lights come on when you push the button but goes right back off

----------

godsdiablo said:
Had that problem in my 05 I had to replace the master window switch 15883319 $150
Im confused, this other door switch cluster with the window and mirror controls fixed your heated seats from coming on by themselves?
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
fivel said:
No lights came on pushing the heat button with the main connecter under the seat disconnected. Now with that plugged back in but the 6 wire heat element connecter(ibelieve) unplugged the heat indicator lights come on when you push the button but goes right back off
I would get ahold of a tech-2 and check the seat module for codes
Makes me wonder if your seat module is bad
 

·
Registered
'09 V
Joined
·
169 Posts
The car can activate them itself if it's cold. When I use remote start in the winter it does it automatically. Maybe there's a sensor that's acting up and making it think it's cold outside.
 

·
Registered
2005 Cadillac Escalade
Joined
·
1,177 Posts
I replaced mine and haven't had the problem since (master window switch only NOT the heated seat switch )

Mine would light up and turn on and off all day long
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
flyingdutchman said:
Maybe a broken or burnt element in the seat
Broken or burnt element won't cause this as mine has a bad element in the driver's seat bottom(it just randomly kicks off when I use the warmer)

----------

HUGN*RDS said:
The car can activate them itself if it's cold. When I use remote start in the winter it does it automatically. Maybe there's a sensor that's acting up and making it think it's cold outside.
You must have a aftermarket start system
 

·
Registered
'09 V
Joined
·
169 Posts
Broken or burnt element won't cause this as mine has a bad element in the driver's seat bottom(it just randomly kicks off when I use the warmer)

----------



You must have a aftermarket start system
You're right that it is probably different than yours, I didn't think. I have an 09 cts and that's a factory setup with the remote start.
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
HUGN*RDS said:
You're right that it is probably different than yours, I didn't think. I have an 09 cts and that's a factory setup with the remote start.
The escalade didn't get remote start till 07 then it was only on certain trims(I think)
 

·
Registered
Joined
·
338 Posts
Discussion Starter #12
godsdiablo said:
I replaced mine and haven't had the problem since (master window switch only NOT the heated seat switch ) Mine would light up and turn on and off all day long
I guess i will try that then, thanks.
You are the only one ive read from who has actually fixed this problem.
Suburbans snd tahoes do the same and they dont have an answer for it on their forums so thanks.
 
1 - 12 of 12 Posts
Top