Cadillac Owners Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I haven’t really looked into this problem yet, but I don’t wanna be chasing stuff without knowing a plausible cause first. South Carolina gets cold in the winter and it’s just hit till now I haven’t really cared because it’s been fairly hot. Sense I got my 06 esv my front heated seats will turn on for a brief couple seconds and then turn off, Before we get to deep I want to note that the driver front seat is not original to the car I believe it’s been pulled from a Chevy truck/suburban but it has all the functions of the Escalades (I think) seat just different leather. However the passenger front will run right back off the driver seat will stay on for about 15-30 seconds or so then turn off the first time then eventually won’t turn back on, I got curious and checked the back seats and no lights come on for them they don’t get warm and I can tell they aren’t working but that’s after sitting in them waiting for them to turn on for about 5 minutes or so. Could this be a relay or some sort of control module that needs to be replaced? As far as it seems none of the heated seats work except the driver seat that’s not original to the car even then it works for only a brief period of time and it makes a clicking noise when it turns on or off but only the driver seat will make a noise. If anyone has had this problem I would like to know what your solution was.
 

· Registered
Joined
·
1,028 Posts
I haven’t really looked into this problem yet, but I don’t wanna be chasing stuff without knowing a plausible cause first. South Carolina gets cold in the winter and it’s just hit till now I haven’t really cared because it’s been fairly hot. Sense I got my 06 esv my front heated seats will turn on for a brief couple seconds and then turn off, Before we get to deep I want to note that the driver front seat is not original to the car I believe it’s been pulled from a Chevy truck/suburban but it has all the functions of the Escalades (I think) seat just different leather. However the passenger front will run right back off the driver seat will stay on for about 15-30 seconds or so then turn off the first time then eventually won’t turn back on, I got curious and checked the back seats and no lights come on for them they don’t get warm and I can tell they aren’t working but that’s after sitting in them waiting for them to turn on for about 5 minutes or so. Could this be a relay or some sort of control module that needs to be replaced? As far as it seems none of the heated seats work except the driver seat that’s not original to the car even then it works for only a brief period of time and it makes a clicking noise when it turns on or off but only the driver seat will make a noise. If anyone has had this problem I would like to know what your solution was.
Maybe a bad relay or fuse but I’ve never had or seen this problem. The new Escalades 2007-2014 are prone to have heated seat problems which I have experienced but the whole set up is different on these systems than the ones on an older one. The 2002-2006 have seat pads that get hot in the seat and then 2007-2014 they moved to a setup where there is a fan under the seat that I’m assuming has a heating coil in that the air passes over to get warm. The 2007-2014 has its own control module for the heated seats and one of the connectors is prone to corrode. This doesn’t necessarily pertain to your vehicle but thought I would put it out there.
 
1 - 3 of 3 Posts
Top