Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
I have a 97 concours and my Heat isn't working when I turn on defrost. Also it seems like it takes forever for the heat to kick on when the car is I just have on normal heat. I have turn on the recirculation button just to get the heat to come and even then it takes about 10-15 min to do that. I wanted to know what could be wrong.

ETA: I also have a message saying check coolant and I know my Resevoir tank needs to be replaced. So could low coolant be a problem?
 

·
Registered
2003 STS w/BoseNav, 1993 Deville, 1985 Deville
Joined
·
1,089 Posts
This could be a low coolant problem. Have the cooling system checked as soon as you can.

When the heat finally comes on, is it nice and HOT?
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
thu said:
This could be a low coolant problem. Have the cooling system checked as soon as you can.

When the heat finally comes on, is it nice and HOT?

yeah it's hot after finally comes out, but it just takes for freaking ever. Also I know I need a new a/c compressor, but I have to wait for money for that.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
If you are loosing coolant, you may have air in the system, which would cause the heat problem you discribe. It could also cause much worse and much more expensive problems. Get that surge tank replaced ASAP.
 

·
Registered
1998 Deville D'Elegance
Joined
·
133 Posts
:yup: If you are low on coolant that COULD cause the slow heat problem.... how hot is the car running??? Also a thermostat stuck open would cause the car to take a long time to heat up, watch your temp as you go (watch the road too!) and see if it take more than a few minutes to get to around 190-195 degrees. My 98 Deville takes 3 to 4 minutes to get to full temp at 50 degrees outside temp. Heated seats help with the cold too... I leave the heat off and turn the seats on till the car warms up.
 
1 - 5 of 5 Posts
Top