Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
SRX
Joined
·
7 Posts
Discussion Starter #1
Hi All,

need a bit help... I purchased new headlights from amazon and somehow my wires were cut after i took my car to the shop. I argued and argued with shop and they didn't do anything to help.
So I put in a warrenty to get the headlight housing replaced thinking it was that or the bulb, even bought new HID's... well got my warrenty replaced headlight assembly... put them in and the headlights them selves
are not working. the DRL and the indicators work fine. I checked the fuse and the connection etc... These are brand new assemblies mind you so i'm all out of ideas, and on top of that there's new HID kit and new error eliminators.

http://www.amazon.com/SPPC-Projector-Headlights-Plank-Bar-Cadillac/dp/B00O83HGIY/ref=sr_1_5?ie=UTF8&qid=1430506431&sr=8-5&keywords=srx+headlights
 

·
Registered
SRX
Joined
·
7 Posts
Discussion Starter #2
quick update so went to AUTOZONE and thought maybe ODB reader will give me something. NOTHING
then checked every single fuse still nothing noticed there is no fuse for low beams... only for high beams...
the little LED lights on the side work fine and so does the high beam and so does the turnsignal....
NOT Sure what else to check. also unplugged the bulb wire and checked it with the fuser checker, and no power is going to the assembly for the low beams.
 

·
Registered
SRX
Joined
·
7 Posts
Discussion Starter #5
there is no fuse in those area... and the headlights worked fine. I even tried to put in fuses in there but still nothing.
 

·
Registered
2013 SRX FWD Performance - Xenon Blue / Shale-Brownstone
Joined
·
296 Posts
I've no idea then. I also admit it's difficult to comprehend what your exact situation is.
Indeed, it would help if they would start out with the model year and trim (i.e.: whether the care came w/ factory HIDs or not). Stating that you purchased some HIDs from Amazon (obviously not factory replacements) and then stating that the wires were cut after "taking it to the shop". WHY did they take it to the shop? To have the non-factory HIDs installed? If so, its not a surprise that some wires were cut and the install wasn't totally successful. Then it's not clear how they made the leap from cut wires being the cause of needing new housings (seems that only a splice would be needed). Confusing to say the least.

I'd start by fixing the wires that were cut, then re-reading the HID kit installation instructions. The clue is in there.
 

·
Registered
SRX
Joined
·
7 Posts
Discussion Starter #8
hey fellas sorry for the confusion.
still do not have working low beams.
2010 Cadillac SRX Premium no OEM HIDS.

So I originally had a problem where my head lights had moisture in them. I ended up purchasing a HID kit from amazon. which works (Since I tested them on another car) I also purchased new headlamp assembly http://www.amazon.com/gp/product/B00LWANUZ4?psc=1&redirect=true&ref_=oh_aui_detailpage_o08_s00

the wire harness that I used so DRL can stay on and not flicker was from DDM Tuning.
what had happened was the wire harness some how touched a hot zone in the car and the two wires + - touched.
well since then the low beams do not work. I actually got the HID's warranty replaced and also the headlamp assembly. I took it to a shop and they were not able to figure it out and also checked all the fuses none were burned.
I am all out of ideas. Final thing would be to take it to the dealer and let them diagnose it but I thought I ask here first for any other suggestions.
I hope that is a bit more clear.

I also put the OEM headlamps back on, however the low beams still do not work. High beams, turn signals works just fine.
 

·
Registered
'14 SRX4 Premium silver-coast/shale-brownstone
Joined
·
709 Posts
It could be your PCM needs updating now that you're running HIDs. Factory non-HID SRX's have separate lamps for High and Low beams. The high beam is in the projector 'eyeball' while the low is outside (below, in the reflector). The low beam is also the DRL. In a factory-equiped HID SRX the low and hi are the same lamp, located in the projector with the DRL located below in the reflector. So your non-HID SRX's computer is trying to run the DRL lamp as your low beam, and not using the HID located in the projector eyeball.

Max

Edit. I reread my own post, and am thinking I may be wrong, since you have error eliminators and are crossing wire harnesses for power feeds to lamps. Not sure now, since you indicate you did an accidental +- bypass touch. Something blew.

Max
 

Attachments

·
Registered
SRX
Joined
·
7 Posts
Discussion Starter #10
Thanks MAX that is what i think too. I am going to put my OEM's and take it to the dealer! frustrating but I think have I have no choice.
 
1 - 10 of 10 Posts
Top