Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
ZIP
Joined
·
51,864 Posts
Discussion Starter #1
Went for a long drive on Wednesday and it was raining all day. Since then, my Ground Control is squeaking and creaking like mad all the time! This is the same noise that kept me from going to Gingerman in May except it's twice as loud.

What my shop ended up doing was adding a shim and greased the sucker to temporarily keep the noise down. But it got almost unbearable. You had to have the windows down and the music up to drown out the noise. The shop has checked it over and found it's just noise from the bumpstop.

So this morning I slobbered the top of the strut mount in Mobil 1 grease. The noise is gone for the most part. And to be honest, if that's all it needs every 3-4,000 miles of driving, I can live with that.

Now, a couple had mentioned hearing a light squeak in the wet. But this was anything but light. Anybody else having a hard time keeping the noise down on their Ground Control???
 

·
Registered
CTS-V
Joined
·
18 Posts
I've had 'light' squeak comming from the left front for about a year on my '05.
you hear it every time you go over a speed bump or whenever there is a change in elevation. VERY ANNOYING for a 50K car.
Dealer tried 3 times to fix it: First try, greased it...okay for about a week:
2nd try - Replaced upper and lower control arms...No good:
3rd try - replaced Nivomat strut...still NFG!

I am tired of leaving the car at the dealer...so I am trying to live with it but I do wish there was a permanent fix to this.

Where exactly do you 'grease' the strut?

 

·
Registered
CTS-V
Joined
·
798 Posts
I was getting noise that turned out to be the spring binding on the adjustment collar (front only). Solution: raise the front and rotate the spring about a quarter turn. Lower the car and test drive. Repeat if necessary. Hope that helps.
 

·
Registered
Joined
·
2,114 Posts
I've had 'light' squeak comming from the left front for about a year on my '05.
you hear it every time you go over a speed bump or whenever there is a change in elevation. VERY ANNOYING for a 50K car.
Dealer tried 3 times to fix it: First try, greased it...okay for about a week:
2nd try - Replaced upper and lower control arms...No good:
3rd try - replaced Nivomat strut...still NFG!

I am tired of leaving the car at the dealer...so I am trying to live with it but I do wish there was a permanent fix to this.

Where exactly do you 'grease' the strut?
I get that same exact squeak coming from the front driver's side corner. Seems to be coming from the A-pillar or suspension area. Drives me crazy (as do many other things about this beyotch of machine). Happens over off camber turns (changes in elevation: incline, decline, dip, whatever; like driveways or going over the crown of the road).

Thought it was the suspension. But I'm gonna tell em to try their luck inspecting the hood hinge. Would definitely make it an easier fix. Anyway, let me know if you find a solution.
 
1 - 6 of 6 Posts
Top