Cadillac Owners Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
484 Posts
Discussion Starter #1
i needed some info i think theres a problem with my caddy its wasting lots of gas i mean big time yesterday well i had half a tank and i just drove to school and back to the house and did some errands but didnt got far and it was already less then the second white line and my school aint even that far from my house or could it be the heat well im fromt texas and its been like 115
 

·
Registered
Joined
·
484 Posts
Discussion Starter #4
well i mean its here in the house were it happens and i have checked for leaks and theres none might be the ****ing spacer
 

·
Registered
Joined
·
6,888 Posts
The only thing I could think of is a faulty gas cap and the gas is evaporating through it. One of my employee's lost a gas cap on a work truck and we were losing alot of gas until we got a cap back on there.
 

·
Registered
Joined
·
484 Posts
Discussion Starter #7
well im getting 14.5 and i mean im almost only going 45 or less but damn could it really be the gas cap i mean becouse with the heat were going through and with a faulty gas cap no wonder becouse its only in the day this happens to me at night i mean doesnt go down anything
 

·
Registered
Joined
·
175 Posts
Spittin Game said:
14.5 is good. I get only 11-12.
Im with you, the best I ever got was 11.4 mpg. Do the newer 03,04's get better mileage, or are some of you guys coasting down the road most of the time.
 

·
Registered
Joined
·
6,888 Posts
csmooth79 said:
Im with you, the best I ever got was 11.4 mpg. Do the newer 03,04's get better mileage, or are some of you guys coasting down the road most of the time.
I have a 03 with 22's and I usually get 13 MPG. I have the A/C on all the time. I thought I was getting terrible gas mileage. I thought it was supposed to be around 15 city and 17 highway.
 

·
Registered
Joined
·
269 Posts
Escalade on 22's with K&N CAI and Corsa exhaust and i'm getting 14mpg city & 18mpg hwy with AC on all of the time and yes this is the 6.0L AWD go figure.
 

·
Registered
Joined
·
26 Posts
my 05 ext gas gauge is tollally SHOT! ill have a full tank and 10 miles later the gas light comes on lol im getting it checked this week u should do the same
 

·
Registered
Joined
·
6,888 Posts
We just went through the problem with the speedometer. The truck could be in park and we were doing 80 to 120. Every time we turned the truck off for the night and started it it would drop 20 mph it was crazy. It did this periodically went into the shop 4 times with the problem they said it was fixed and would always happen again. Just last Wednesday they finally replaced the whole speedometer. Just beware it may be 2 totally different problems. We never had a problem with losing gas because of this.
 

·
Registered
Joined
·
10,429 Posts
I thought this thread was going to be some kinda Beano commercial......



Reading this makes me greatfull for the mileage I get in my little old DeVille.


OK, sorry, hijacking over now.....

:leaving:
 

·
Registered
Joined
·
4 Posts
I had the same problem with the spedometor when i had 20's on mine and they ended up having to replace it. I average 15.2 mpg with mine and just started using a new fuel additive and im doing even better than that now
 

·
Registered
Joined
·
17 Posts
If your gas cap were bad, I think you would be throwing a SES code. I've known someone who left their cap too loose--in a couple miles the SES light came on. The light went away after a few miles once the cap was tightened. This is one of the parameters your computer monitors for emissions control.
 
1 - 20 of 20 Posts
About this Discussion
19 Replies
12 Participants
danksontl
Top