Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
2009 CTS PI
Joined
·
15 Posts
Discussion Starter #1
DILEMMA: Have two running DeVilles, 2000 and a 2002, the 2002 has a blown head gasket so I scored on a 2000 and have been switching out parts from one to the other, today I pulled the fuel pump from the old one to put in to the new one because the new one has an erratic fuel gauge and I had just fixed it on the old one so I thought, hey, ill just swap'em. Everything went fine on the re-install and the gas gauge is working fine but NOW it won't start. I don't hear the fuel pump kicking on or if it is I can't hear it. It just cranks and sounds like it's not getting any fuel, obviously. Any thoughts?
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,270 Posts
DILEMMA: Have two running DeVilles, 2000 and a 2002, the 2002 has a blown head gasket so I scored on a 2000 and have been switching out parts from one to the other, today I pulled the fuel pump from the old one to put in to the new one because the new one has an erratic fuel gauge and I had just fixed it on the old one so I thought, hey, ill just swap'em. Everything went fine on the re-install and the gas gauge is working fine but NOW it won't start. I don't hear the fuel pump kicking on or if it is I can't hear it. It just cranks and sounds like it's not getting any fuel, obviously. Any thoughts?
==================
check fuses and relays -

check for codes -

check for fuel pressure at the fuel rail -
 

·
Registered
2009 CTS PI
Joined
·
15 Posts
Discussion Starter #3
==================
check fuses and relays -

check for codes -

check for fuel pressure at the fuel rail -
Ya so to follow up on this it actually turned out that when I put the pump back in, I knocked a lead off one of the terminal to the pump. It was my fault, errrrr.
 
1 - 3 of 3 Posts
Top