Cadillac Owners Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
401 Posts
Discussion Starter #1
I have a suspected fuel pump issue. When the key is turned on, I hear a rumbling sound coming from under the car. ( deep and hollow).
I actually noticed it yesterday for the first time, it's unmistakable. Soon after, the car sputtered and died, and wouldn't restart. (towed home)
I had someone turn the key while I was under there and it's coming from the gas tank. I now have the tank out as well as the fuel pump assembly. Is it possible to just change the motor? Has any done this before?
Also, in whole, does this sound a fuel pump issue?

TIA
 

·
Registered
94 ETC,97 STS
Joined
·
3,531 Posts
You should have checked Fuel pump pressure before you pulled the tank....put it all back together and check it!!!:histeric::histeric::histeric:

I couldn't resist...ROFL

You can hook it to a battery and check operation but be really careful of fumes and sparks, not a good mix.

Changing just the motor is a good possibility in that year range. Did you look at Autozone or Rockauto or Checker's web site to see what's available?
 

·
Registered
Joined
·
401 Posts
Discussion Starter #3
I tested pressure at the fuel rail...I don't have a fuel gauge tester. key on or off, the pressure was the same....It came out at a stream...not misted as you would expect at higher psi. Did I forget to mention that?...:)

I'll check for motors now...
thanks
 

·
Registered
1997 SLS
Joined
·
550 Posts
I had fuel pump go out on my 97 SLS last year too...The symptoms were similar to yours...sputtering while trying to start and then endless cranking (no codes). It's a dangerous change-out, and in Tech Tips, someone describes how to do it, but it sounds like you've already dropped the tank. That's the worst of it. If your car has more than 70K miles on it, you might as well change it...see tech tips. Good luck.
By the way, I paid the dealer $1000 to do it!
 

·
Registered
94 ETC,97 STS
Joined
·
3,531 Posts
mikeay, try putting in zip 85022 on that. YIKES!!! What a difference!!!

How about ebay to get a better price in CA? What kind of fees to get it delivered to CA?
 

·
Registered
Joined
·
401 Posts
Discussion Starter #8
I have had parts shipped from the states before....it works out to be about the same. That also depends if the part was "Made in the USA" (for duty). You pay higher duty if the part was "Made in China" and imported into the states, and then I come along and buy it and have it shipped to canada. You can pretty much double the price.

I need this pump today, so I'm paying the 450.00. I couldn't find the pump anywhere local.

Thanks for the help.
 

·
Registered
Joined
·
401 Posts
Discussion Starter #9
Well I have good news and bad news...I changed the pump and sending unit. Car now starts. I also changed the pig tail harness ( it came with the pump assem.). I must have screwed up the wiring ( not sure how), colors matched, so now I'm always on empty. GOing to have to recheck at a later date.

Another good thing, is my ac works again! I guess disconnecting the battery for the two days helped reset the system.

One more good thing, I found a broken air line from the compressor motor. Fixed that too.

The wiring for the pigtail is;
Black and grey - fuel pump
Black/white, purple and orange - sending unit.

Existing wires have the same colors.

Does anyone have a diagram?
 
1 - 11 of 11 Posts
Top