Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just got a '99 Eldorado (44k mi) and everything seems to work beautifully ... except the fog lights. I push the foglight button and the parking lights come on (the manual says they're supposed to) but without the fog lights.

I checked the bulbs and fuse and they looked okay, but i didn't check the maxifuse. I figured if the maxi fuse were blown, then the parking lights wouldn't come on either. Is that accurate? Does anyone have any suggestions?

I did get the extended warranty. But with the $100 deductible, I wanted to see if someone here had a solution first.

Thanks!

Aaron
'99 Sable Black Eldorado
Los Angeles
 

·
Registered
Joined
·
6,471 Posts
Ok Aaron,
The body control module controls the fog lamps. You hit the switch and the BCM sends the signal to the relay, which in turn sends the power to the lamps and indicator light.
First question would have to be, is the fog lamp indicator light on?
If so, the problem is the lamps themselves, or related wiring.
If the indicator is NOT on, then chances are either the switch, relay, or fuse is bad.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thanks Kevin. The indicator light does go on and everything operates as the manual indicates (taillights, parking lights go on etc), except the foglights don't come on as if there were no bulbs. Since there are bulbs and they look fine, i'm going to assume it's wiring and call the dealer.

thanks for your help!

Aaron
 

·
Registered
Joined
·
6,471 Posts
There is one simple thing to check. Both fog lamps use a single ground. If, for some reason that ground is bad (loose or broken wire), both lamps will be inop. The ground is on the right side of the radiator support. It should be a black wire that's basically screwed to the metal.
 
1 - 6 of 6 Posts
Top