Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of August's Ride of the Month Challenge!
1 - 2 of 2 Posts

·
Registered
06 STS;05 DTS;03 STS;96 Fleetwood;95 Deville
Joined
·
75 Posts
Discussion Starter · #1 ·
Hey everyone, lately I've started having problems with the factory XM radio in my wife's '03 STS. None of the stations work anymore, and instead it just says "Loading XM" and "Channel Unavail". I called XM but all they seem to be able to do is to set a radio "reset" signal, which hasn't helped. I also cannot get the Preview Channel #1 so I suspect something is wrong with my XM tuner box. Does anyone have an idea on how to get it working again?

Not having any luck there, I took the tuner box out of my 04 DTS (which isn't active) and put it in the STS. Then, I was able to get the preview channel and the Emergency channel 247 to work just fine. However, once I started the STS, the Theftlock kicked in and now the display says "XM Theftlocked" and won't do anything. Is there anything I can do to reprogram the XM box to work in the STS, or is that a dealership function? Any ideas on either topic would be appreciated! Thanks, Doug
 

·
Registered
2014 XTS V-Sport Platinum
Joined
·
2,772 Posts
The dealer is going to have to reprogram the VIN from the STS into the unit to remove the theftlock. Unless you have access to a Tech II scan tool. My Cadillac dealer gets about $100 for this...Chevy dealer about $60.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top