Cadillac Owners Forum banner

Everything electronic is dead, where do I start?

676 Views 5 Replies 4 Participants Last post by  SvdSinner
In my continuing saga of my "3 day repair" on my CTS (getting close to week 11 :(), I finished installing the new engine, reconnected the negative battery terminal to the battery, and was going to try to do a first start. However, the remote did not unlock the doors, and when I used the physical key to get inside, it still acted as though my battery was disconnected. The "key" wouldn't turn at all, and nothing I tried was operational. I check the battery, it was full. I checked the positive terminal in the engine bay and it is showing 12V.

So, I can think of 6 possibilities:
1) I somehow have some really important connector either disconnected or loosely connected so that no contact is made. Obviously while replacing the engine, I disconnected and reconnected just about everything on the wire harness, plus the engine block to body ground wire.
2) I blew some sort of master fuse. I couldn't find anything in the engine bay fuse box, nor could I see any fuse labels that seemed like they might be capable of causing such an issue. I haven't checked the rear fuse-box yet, since my assumptions are that: A) Since power is making it to the engine bay, there isn't a master fuse in the rear that is blown. B) Everything I've touched is in the engine bay, except for the negative battery cable.
3) The main computer is fried.
4) There is some immobilizer feature that needs to be reset after everything has been disconnected/reconnected.
5) After being disconnected for a couple weeks, the car has forgotten my key-fob and won't turn on. (Although I'm pretty sure that it would show me something on the dashboard display if the key fob wasn't detected.)
6) A problem with the fake ignition key that has it locked in the off position. (It doesn't turn at all, and I don't know if that is normal with all the electronics off.

Details that might matter:
  1. I didn't remember to disconnect the negative battery terminal at first, so there are a few hours I could have fried things
  2. When pulling the starter motor, I accidentally touched the positive wire to the frame and got a big spark. (This is what reminded me to disconnect the battery)
  3. I did pull the ECU out of the car before #2 happened, so it was safe from that big spark. This obviously assumes I hadn't unknowingly did something else less dramatic to kill it before I pulled it out of the car.
  4. I am aware of 5 points where the engine/harness is grounded and that I have checked: Passenger side head grounded to harness, Passenger side of engine block to passenger strut tower, passenger-side harness to body, a few inches below the fuse box, and driver side harness to driver side head. If I somehow missed a ground, that could be a culprit.
  5. I had a few things not connected yet: the windshield wiper motor, the front bumper, the driver side headlight, and have one two-prong plug on the driver's side rear that I can't figure out what it goes to. I don't think any of that should prevent the car from starting, but I haven't found anything authoritative on what the minimum amount of things to plug in to allow basic functionality is.
  6. I wasn't super-thorough checking for things that didn't work. If the ECU is somehow completely dead, are there things I should expect to work? (I was a bit too frustrated to think logical when nothing worked.)
Where do I start to troubleshoot what is preventing everything from working? How do I know if the ECU is dead or if something else is the culprit?
See less See more
1 - 1 of 6 Posts
Is this a keyless or keyed-entry vehicle?

I know with keyless, there is a slot in the center armrest to insert your key fob when power is low (in the fob) and you need to start the vehicle. I'm not sure if this carries over to the keyed version but it's worth trying if the slot is there. To be clear, I'm fairly certain you need the key fob inserted still containing the key blade for this to properly work.
1 - 1 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.