Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Recently I got a 2002 escalade and just started having a few problems with it. When it rains heavy, water leaks around the overhead console. Figuring either the sunroof or windshield gasket?? Now for the big problem. It is my wifes car and she usually lets me know when something isnt right and today she stopped in at work with me and showed me what was wrong. The service ride control light flashes on the dash, low fuel flashes on the dash, the gas guage reads E but I know there is plenty of gas in it. The abs light is on on the dash and the outline for the shift indicater on the dash is missing. I also saw the odometer clear but then go back to normal. I would greatly appreciate any help on this. I dont know where to begin.. Thanks
 

·
Registered
Joined
·
437 Posts
Wow, serious electrical problem there. Looks like your entire cluster panel may need to be replaced, the things that are acting up are not related (except for ride control and abs), so that makes me think it is most likely your cluster panel is going wacko. Definetaly have the dealer look at it tho.

Water, most likely your sunroof weather seal.
 

·
Registered
03 Escalade, 06 SRX
Joined
·
6,888 Posts
If you have Onstar. Ask them to do a diagnostic scan of the computer for error codes. That would be a good start, But I see a trip to the dealer in the near future. Hopefully you are still under warranty.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Its out of warranty. I work at a garage for my dad I have a snap on Modis scanner and I plan on checking it for codes but I was hoping that someone might be able to point me in the right direction. I have never seen anything like this. I dont want to take it to the dealer if I dont have to. Thanks again for your help
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
I asked my wife to see if the dash ever got wet when the water leaked in and she said it was just wet at the cupholders. at first I thought that maybe water got in. Im going to call the gm dealer where we get our parts at the garage and ask them for a little guidance. If anyone else has any ideas please let me know.. thanks again
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
I just went out and started the escalade and everything is back to normal. I took it for a ride and all seems well. Now this really has me baffled
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
The IPC is losing communication or you could have a power or ground problem.

Depending on the year and wiring, I have seen some IPCs that ground on the engine block, there is a bolt low on the back of the engine right behind the intake that has 3 or 4 ground wires on it. Sometimes this harness is stretched too tight and one of the ground wires (usually the one for the IPC) will break inside the insulation. This can cause intermittent problems like you describe. Also it's not uncommon for the ignition switch to go bad and cause low voltage on one of the ignition circuits. If you can turn the key off and back on to fix this problem (if it happens again) you might need to replace the ignition switch.
What's happening is the IPC is losing data that it gets from other modules.
The fuel level reading and transmission shift indicator are data that's coming from the PCM. If communication is lost those things will default to zeros.
I doubt it's the IPC itself, although it is a possibility.
 
1 - 9 of 9 Posts
Top