Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello and good day.
I have a 2008,
Cadillac Escalade EXT and the cruise control system and the backup camera are not working.
I checked online and thought it might be the #43 fuse, which is responsible for both.
I checked the fuse, and it looks perfectly fine, the filament is not at all burnt out.
Any ideas would be appreciated.
Thank you for your assistance in advance.
Keith
Edited by Moderator. Sub.
 

·
Registered
CT6 plug-in, ELR, Tesla Model X, Ford Fusion Energi
Joined
·
675 Posts
You're posting in the wrong forum. This forum is for the upcoming Cadillac Celestiq.

Also, I strongly recommend that you never post your e-mail address in a public forum such as this, especially since yours appears to disclose your full name (Keith **). It's just ripe for identity theft. Someone with your e-mail address, name, username, make/model/year of vehicle, and country of residence could do a lot of damage to you. Please be more careful online.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
You're posting in the wrong forum. This forum is for the upcoming Cadillac Celestiq.

Also, I strongly recommend that you never post your e-mail address in a public forum such as this, especially since yours appears to disclose your full name (Keith **). It's just ripe for identity theft. Someone with your e-mail address, name, username, make/model/year of vehicle, and country of residence could do a lot of damage to you. Please be more careful online.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Thank you for letting me know.
I didn't get any answers from anyone else.
Have a great day ~ !
Kk
 
1 - 4 of 4 Posts
Top