Cadillac Owners Forum banner
1 - 17 of 17 Posts

·
Registered
2007 Escalade ESV
Joined
·
28 Posts
Discussion Starter · #1 ·
About an hour ago I pulled into my driveway and tried turning off the vehicle but the engine would not turn off.
I had the key in the off position and out of the ignition but it would not turn off. I tried going around the block again
but when I came back it was the same thing. The instrument cluster was dead and I could not shift from park but the
engine was actually running. It was acting as if you had used the remote starter. I was going to try and disconnect
the battery to see if that would help but I let it go to see if it would turn off on it's own like it does when the remote
start is used. Well it turned off by itself about 5 minutes later. I started it again and took it for a boot and when I
returned it turned off normally. I tried starting and turning off the ignition a few more times and it worked every time.
I noticed though, that after the vehicle shut down on its own the check engine light came on the next time it started.
The light is still on and I am sure I can hear a faint beeping coming from behind the dash somewhere while driving for
the first few minutes.

I'm going to take it in and have the codes pulled but I was wondering if anyone here has ever experienced anything like
this before. Or does anyone have any ideas as to what would cause the engine to stay on after the key was out of
the ignition?

Thanks for any help.
 

·
Registered
2007 Escalade ESV
Joined
·
28 Posts
Discussion Starter · #2 ·
I guess no one has any ideas as to what would cause this. Well neither does the dealer. I took it in and they scanned it for
SES codes and the computer had not stored any. They could offer no explanation as to what would cause the engine to stay
running. Am I wrong in thinking that once the SES light comes on, a fault code is stored immediately.
The SES light has also gone away and the vehicle seems to be running fine. Weird.
 

·
Registered
2007 Escalade ESV
Joined
·
28 Posts
Discussion Starter · #3 ·
Holy thread bump Batman!

Me again and same problem is back. Now though, the vehicle stays running every time I try to turn it off. The only way to get it to shut down is to remove fuse number 12, battery/ecm. Has anyone ever come across this? Could it be the ecm or possibly the anti theft module? Any insight would be appreciated.

Edit: It might not matter but I just installed a new battery since the old one was gone. Also, whenever I pull the fuse to get the vehicle to shut off the check engine light stays on even with the key removed. The ses light turns off once the truck starts again.
 

·
Super Moderator
2010 Platinum Escalade, 1996 Fleetwood Brougham
Joined
·
6,511 Posts
Glad to hear it hasn't been for the last 2-3 yrs!! When you reinstall the fuse, does everything come on as it would if the key was in the on position, or do you have to turn the key to the on position??
 

·
Registered
2007 Escalade ESV
Joined
·
28 Posts
Discussion Starter · #5 · (Edited)
When the fuse is re installed it's as if nothing out of the ordinary has happened. I need to put the key back in and start the truck normally. Then once I try to shut it off and take the keys out it stays running.

Edit: I haven't tried removing the fuse or reinstalling it with the key in the on position. I was worried I would be causing more damage ie. a short, overcurrent etc
 

·
Registered
'08 Esky
Joined
·
87 Posts
I'm gonna say ignition module but of course that means a trip to the dealer,diagnosis fees etc..Unless you can find an ignition module at a salvage yard or ebay but then
you'd still have to have your keys reprogrammed.Keep us posted and good luck with that one.
 

·
Registered
2007 Escalade ESV
Joined
·
28 Posts
Discussion Starter · #12 ·
I remember a while back ther was a service bulletin regarding a draw on these vehicles. I think it involved re flashing something and it involved the BCM. I am definitely going to take a good look at the wiring though. Thanks for chiming in.
 

·
Registered
2007 Escalade ESV
Joined
·
28 Posts
Discussion Starter · #13 ·
So, couldn't find the draw and the vehicle starts and shuts off normally now. I guess having it off the battery for a full day reset somethibg that was causing the problem. It woukd be nice to get a definative answer on the nit turning off issue. Next step is back to the dealer to see if the truck needs to have something flashed.
 

·
Registered
2007 Esclade
Joined
·
1 Posts
Dear Spartoron
I have a 2007 cadillac esclade and exactly same thing happened, it was parked out side, it snowed and all battry drainned, then i jacked it up and restarted but then it will not shutoff, so i removed breaker # 12 and it helped, now i have disconeced the battary, so can you please e mail me what other thigns you did, will be very helpful [email protected]

thanks

rasim
 

·
Registered
'01 Pearl White - Sold 10/11, '09 Raven Black :)
Joined
·
734 Posts
Dear Spartoron
I have a 2007 cadillac esclade and exactly same thing happened, it was parked out side, it snowed and all battry drainned, then i jacked it up and restarted but then it will not shutoff, so i removed breaker # 12 and it helped, now i have disconeced the battary, so can you please e mail me what other thigns you did, will be very helpful [email protected]


thanks

rasim

If you checked his profile, the last time he was active was 2 years ago. Maybe he sold the vehicle and moved on like many do on here (who have not been active for a long period of time) ...
 
1 - 17 of 17 Posts
Top