Cadillac Owners Forum banner

1 - 20 of 25 Posts

·
Registered
2004 CTS 3.6, 2004 SRX 4.6 AWD, 2012 CTS 3.6 DI AWD
Joined
·
1,229 Posts
Discussion Starter #1
So this is a new one for me. I found similar threads on STS, escalade and first gen, but nothing 2nd gen cts.

This is the third time this week where after I turn the knob to off, the engine stays running. The nav screen goes down, gauges turn off, etc, but the motor is still on. I know that the fans will typically stay on after turning thr car off, but i am positive that this is the engine staying running. Any ideas? 2012 Sedan 3.6 DI AWD with 58k miles
 

·
Registered
Gone; ‘09 V, ‘13 V coupe. Curr; ‘14 PG Vsport prem w/Kona interior
Joined
·
6,177 Posts
I'd say it might be run-on but fuel injected cars don't suffer that. Something in the ignition? How long does it run?
 

·
Registered
SOLD - 2010 CTS4 Premium Wagon-Diamond White-Cashmere Interior
Joined
·
2,930 Posts
Time to visit your dealer, this MIGHT be a new ignition problem!

Marv
 
Joined
·
12,778 Posts
So this is a new one for me. I found similar threads on STS, escalade and first gen, but nothing 2nd gen cts.

This is the third time this week where after I turn the knob to off, the engine stays running. The nav screen goes down, gauges turn off, etc, but the motor is still on. I know that the fans will typically stay on after turning thr car off, but i am positive that this is the engine staying running. Any ideas? 2012 Sedan 3.6 DI AWD with 58k miles
Hello arw,

I most certainly understand that you would like resolution to this concern. Additionally, we want you to rest assured that your vehicle is operating as expected. Please send me a PM at your earliest convenience if you would like me to look further into this situation. Enjoy your weekend and I will be looking for your message.

Kind Regards,


Brandon M.
Cadillac Customer Care
 

·
Registered
2004 CTS 3.6, 2004 SRX 4.6 AWD, 2012 CTS 3.6 DI AWD
Joined
·
1,229 Posts
Discussion Starter #5
I'd say it might be run-on but fuel injected cars don't suffer that. Something in the ignition? How long does it run?
maybe 15 seconds, running errands today everything was normal. fingers crossed

----------

Time to visit your dealer, this MIGHT be a new ignition problem!

Marv
dot make me regret not buying the extended warranty!!!
 

·
Registered
2008 CTS4 3.6 LY7
Joined
·
236 Posts
Try opening the drivers door next time that happens. Had similar issue in my Old 2006 CTS. In these newer cars when you turn the key your telling the computer to start the engine....
 

·
Registered
2004 CTS 3.6, 2004 SRX 4.6 AWD, 2012 CTS 3.6 DI AWD
Joined
·
1,229 Posts
Discussion Starter #7
Try opening the drivers door next time that happens. Had similar issue in my Old 2006 CTS. In these newer cars when you turn the key your telling the computer to start the engine....
Stays running even with door open. Thats how I first noticed, got out and still saw steam coming out of tail pipes

----------

New update!!!

The engine actually shuts off and restarts when i turn it off.

Also, have yet to research on forum, but my reverse lights are on constantly!

----------

any tips on checking ignition switch and relays?
 

·
Registered
2004 CTS 3.6, 2004 SRX 4.6 AWD, 2012 CTS 3.6 DI AWD
Joined
·
1,229 Posts
Discussion Starter #9
Now having issues with the backup camera.

What the heck happened to my car?
 

·
Registered
2010 CTS 3.6 RWD Sport Wagon (traded in for a 2011 Lexus LS460 on 12/20/17)
Joined
·
321 Posts
How old is the battery? You'd be surprised at what a failing battery can do to the electronics on these cars.
 

·
Registered
2004 CTS 3.6, 2004 SRX 4.6 AWD, 2012 CTS 3.6 DI AWD
Joined
·
1,229 Posts
Discussion Starter #11
How old is the battery? You'd be surprised at what a failing battery can do to the electronics on these cars.
It's the original battery. So little more than 3 years.


The backup camera is either a blank screen or very pixel-ly . The lens itself has moisture on the inside and is cloudy.

The reverse lights haven't come up again. But the engine running is at least once a day
 

·
Registered
Gone; ‘09 V, ‘13 V coupe. Curr; ‘14 PG Vsport prem w/Kona interior
Joined
·
6,177 Posts
I agree with Dave1442397 about crazy things failing batteries can cause.
However, If you get the battery tested and it's good it might be a good idea at this point to have the dealership check it out. So far none of the symptoms have been a safety concern but it seems like things are getting worse.
 

·
Registered
2010 CTS 3.6 RWD Sport Wagon (traded in for a 2011 Lexus LS460 on 12/20/17)
Joined
·
321 Posts
It's the original battery. So little more than 3 years.


The backup camera is either a blank screen or very pixel-ly . The lens itself has moisture on the inside and is cloudy.

The reverse lights haven't come up again. But the engine running is at least once a day
That doesn't sound so much like a battery issue as maybe a problem with water getting into things. I'd say take it to the dealer.
 

·
Registered
SOLD - 2010 CTS4 Premium Wagon-Diamond White-Cashmere Interior
Joined
·
2,930 Posts
That doesn't sound so much like a battery issue as maybe a problem with water getting into things. I'd say take it to the dealer.
What did Cad Customer Service say? Whether you're in or out of warranty, with the problems GM has had with ignition switches, I'm guessing they will take care of your ignition switch problem. Unlikely that a 3 year old battery is the cause.
Good Luck, Marv
 

·
Registered
2004 CTS 3.6, 2004 SRX 4.6 AWD, 2012 CTS 3.6 DI AWD
Joined
·
1,229 Posts
Discussion Starter #15
Dropped at dealer last night. Got call this morning. They are not familiar with the problem. But they will investigate and get back to me during the week
 

·
Registered
Gone; ‘09 V, ‘13 V coupe. Curr; ‘14 PG Vsport prem w/Kona interior
Joined
·
6,177 Posts
Hope whatever is wrong is covered by warranty. Let us know how it works out.
 
C

·
Guest
Joined
·
0 Posts
No more bumper to bumper warranty. I doubt something like this is covered under powertrain
Now would be a good time to allow customer service here to help you because they might be able to get you some goodwill assistance with the repairs.
 

·
Registered
2016 CTS Premium 3.6 AWD
Joined
·
218 Posts
No more bumper to bumper warranty. I doubt something like this is covered under powertrain
Almost everything in these cars is controlled by computer. Since you are out of warranty, It might be worthwhile to reset everything. I have not done this myself, but some have advised disconnecting the battery. Leave it disconnected for 30 minutes, then touch the negative and positive cables together (both cables disconnected for this). Then Reconnect the battery. Do this at your own risk -- you will lose just about every setting that your car has been remembering.
 

·
Registered
2004 CTS 3.6, 2004 SRX 4.6 AWD, 2012 CTS 3.6 DI AWD
Joined
·
1,229 Posts
Discussion Starter #20
Almost everything in these cars is controlled by computer. Since you are out of warranty, It might be worthwhile to reset everything. I have not done this myself, but some have advised disconnecting the battery. Leave it disconnected for 30 minutes, then touch the negative and positive cables together (both cables disconnected for this). Then Reconnect the battery. Do this at your own risk -- you will lose just about every setting that your car has been remembering.

We will see what the dealer says. I could care less about the backup camera but the engine trouble I wouldn't be comfortable doing more than trying to replace the ignition switch myself. The reverse lights who knows but they stopped. I trust this dealer so I think they will be fair.
 
1 - 20 of 25 Posts
Top