Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I recently purchased a 89 deville and after 300 miles on the expressway at 70mph (with cruise on or off) I started to notice a shutter or vibration when the car would start to go up an incline. It would only do it right at the start of the incline and would not act up again untill the start of another incline. At 55mph I did not notice the problem. Could this be a fuel problem? Does anything think I might need to replace the fuel filter....I am sure its the original and there is 128k miles on the car. Any other info would be appreciated.
 

·
Registered
Joined
·
6,735 Posts
educated guess would be a cracked spark plug insulator. ck for carbon tracks on the white portion of the plug. also another thought is arching spark plug wires. i think what you are feeling is a misfire under light load against the normal trans torque converter lock up. i strongly agree to replace the fuel filter based on age, not to cure the complaint. my experience with restricted fuel flow is bogging or lack of power reaching the top of a grade or at wide open throttle. a restricted fuel filter can over heat and damage an electric fuel pump. hope this helps, Bill.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for the info, I was planning on changing the plugs/wires/cap/roter soon because I have no idea when they were changed last and I doubt the dealer did it before they sold it. I also have a spare fuel filter laying around that was for my lesabre, and also fits the deville so im going to put that on for sure.

I plan to use Bosch Platinum plugs/wires
and order a AC Delco cap/roter from the dealer unless someone knows of a better replacement that is cheaper.

Thanks again.
 

·
Registered
Joined
·
6,735 Posts
based on personal experience i would use the delco dual patinum plugs for the 4.9 engine, not the bosch. cost virtually the same, delco will last longer. also some advice on plug wires. make sure they are routed exactly like from the factory, use all the seperators and retainers. the rear wires closest to the firewall tend to burn on the exhaust manifold! report back after on this thread.
 

·
Registered
Joined
·
6,735 Posts
I'm Aware Of Your Engine Being A 4.5, But The Upgraded Delco Plugs List For The 4.9 . This Might Be A Bit Of Superstion ? But If I Own A Gm Car I Use Gm Tune Up Parts, If Ford, Motorcraft. I Dont Want To Do The Job Twice Because I Experimented. This, Of Course Is My Personal Feeling.
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
2 Participants
carnut
Top