Cadillac Owners Forum banner
1 - 14 of 14 Posts

Registered
08 CTS with Sports Package and 165k miles
Joined
74 Posts
Discussion Starter · #1 ·
As I mentioned in my other thread, I am replacing the engine in my CTS. (It is the LLT, direct injection engine) I spent some time reading through the service manual to see what is involved so I can figure out as many questions as I can before the new (used) engine comes arrives. Addtionally, I'm throwing out a line for any battle-tested suggestions from anyone who has done this before.

  • The service manual says I have to drain the A/C, disconnect it, and then reconnect when the new engine is installed. While I have a friend with the equipment to do this, I know many cars have work-arounds to swap the engine without ever opening the A/C lines. (IOW, disconnect the compressor from the engine, and leave it in the engine compartment while swapping the engine.) Is it possible on the CTS to engine swap while keeping the A/C intact?
  • The new engine is from a reputable salvage place, but I would like to check it over as much as is reasonable before installing it. What are sensible tests that can be done with it on my engine stand? I can visually inspect the cams, etc. I can do a leak-down test on the cylinders. Are there other things I can/should check on it before install?
  • Since I just installed several brand new parts (water pump, timing components, spark plugs) on the dead motor, should I move them to the new engine or just let them be? I'm back and forth in my head which adds more risk: Trusting the unknown timing components or cracking open the engine to swap the components. Thoughts?
  • What should I lubricate in the new engine before cranking it for the first time? I'm assuming it has been sitting long enough that all previous lubrication has drained into the pan and that cranking it without priming things first with oil or assembly lube would be bad.
 

Super Moderator
Go ahead, blame me. Everybody does 馃檮
Joined
18,613 Posts
I can offer zero support on any other engine suggestions, but I would wholeheartedly swap any new components from the original engine to the replacement engine in a heartbeat.
 
  • Like
Reactions: Phat98

Registered
08 CTS with Sports Package and 165k miles
Joined
74 Posts
Discussion Starter · #3 ·
I am replacing the engine in my CTS, and I posted a thread about it in the General Discussion. I didn't get much of a response there, and I wondered if there might be more engine replacement experience in this performance forum.

My two main questions (see the other thread for additional details) are:
  1. Do I really have to drain the A/C, disconnect the compressor, swap the engine and then reassemble the A/C and refill it? Or can I just disconnect the compressor and move it out of the way while swapping the engine? Service Manual say the former, but I don't see why the later isn't possible. However, I don't want to assume I can swap without draining/refilling the refrigerant and then have a big delay if I discover I do have to drain it and have to wait for someone to come with a recovery unit. (I'm NOT going to vent it even if it would be more convenient)
  2. What should I do with the new engine when it arrives? I'll swap over the new parts I just put on the other engine (P/S pump, spark plugs, water pump, timing components) to hopefully save myself replacing them in the next few years. I'll probably do a leak-down test. What are other good practices to do to the new engine before installing it?
 

Super Moderator
Go ahead, blame me. Everybody does 馃檮
Joined
18,613 Posts
Identical threads merged.
Let one thread work for you and others will chime in.
 

Administrator
'05 CTS-V
Joined
9,370 Posts
I agree with Long, it makes sense to take your new water pump and timing components and swap them onto the "new" engine. Obviously that will be more work, but with the timing components being such an important factor in the health of these engines, it would be good to know the condition of what's on the "new" engine before you swap it in.

For the A/C, I think you'll just need to experiment yourself to see if you can leave the compressor hooked up and just move it out of the way. I've done it that way on a couple of different cars and it definitely makes life easier.

I've done a couple of engine replacements with used engines on my '90s Subaru. I never know what to check. On Youtube you can find videos of people that turn their engine stand into a test rig - build a fuel system and wire up the ECU and everything, actually start the engine and run it. At the pace I work, it would take me weeks to do all of that, by which time if I did find something wrong the place I got it from would be like, "Tough patooties, your warranty expired 3 months ago!" :p In your case, if you go ahead and replace the timing components and water pump, you're already going to be giving the engine a pretty good once-over, probably more than most folks would do, so I think you'll be ahead of the game.

As for lubing the engine, if you're pulling the valve covers to inspect the cams, anyway, I'd put assembly lube all over them - bearing surfaces, lobes, tips of the valves (if you can reach them), etc. You can lube all the timing components as you're replacing those. Is there a way to pre-lube the V6s? On LS engines there's a port on the front driver side of the block that you can screw a 16mm-1.5 adapter into and hook up a hose to pump oil through the engine before you start it, so that's what I did when I had to replace my LS6. If you can't do something like that, then you can at least crank the engine over with the starter for a while before you actually start it - that'll get the oil pump to do its job and circulate oil through everything while there's no load on the engine.
 

Registered
08 CTS with Sports Package and 165k miles
Joined
74 Posts
Discussion Starter · #6 ·
Update:
1) Yes, you can absolutely get the engine out without disconnecting the A/C, and without removing all of the front suspension. The service manual bizarrely suggests that you drop the sub-frame/engine/transmission down to the ground, and then remove all the accessories and the transmission before lifting the engine out the top. As I've already pulled the accessories to get to the timing components while the engine was in the car, I had no problem removing stuff and then lifting it out the top.
2) My idea of doing a leak down test before installing was a bomb. Leak down tests need to be done at operating temperatures, which don't happen before installation. 馃槖
 

Registered
'14 CTS-V LongRoof; Audi RS6 Avant; '16 ATS-V Sedan gone; '10 CTS LongRoof gone
Joined
20,934 Posts

Registered
08 CTS with Sports Package and 165k miles
Joined
74 Posts
Discussion Starter · #9 ·
Flipping through the service manual, I discovered there is a pre-lubing procedure. (Remove oil pressure sensor and pump in 1-2 quarts of fresh oil)
And then I discovered that the tool to do it costs almost $400. I think I'll stick with a tablespoon in every cylinder, and a squirt of oil on all the camshaft items.

If I wasn't already on week 9 of a my 3-day repair, I'd make a DIY adapter on my lathe.
 

Registered
08 CTS with Sports Package and 165k miles
Joined
74 Posts
Discussion Starter · #10 ·
I move the timing components over this afternoon. It was definitely a good move. The existing tensioners were about 50% extended.
Additionally, I am finding evidence that I probably had a screwed-up bearing somewhere in the bad engine. The amount of effort it takes to spin the new engine with the plugs out is about 25% of the effort it took to move the old engine with the plugs out. For anyone reading this, the good engine moves easily with an 18in breaker bar on the crankshaft bolt. The bad engine took muscle to move with the same breaker bar.
 

Registered
08 CTS with Sports Package and 165k miles
Joined
74 Posts
Discussion Starter · #11 ·
Everything is mostly installed. Still need a bolt for one of the catalytic converters, and a PCV intake tube. Both are at the local GM dealership ready to be picked up which I will do in the morning.

As mentioned in my other thread I've been panicing for the last day because the car wasn't getting any power. Now that the loose connection is fixed, I tried first start.

She cranked for 10-15 seconds, fired up, and died with a big puff of smoke from the engine compartment. (Not entirely unexpected or necessarily bad. I don't have the exhaust fully hooked up on the driver's side and not all of the PCV tubes are on the engine.) Further attempts consistently gave an immediate fire up for 1-2 seconds and dying with more smoke. The engine doesn't sputter at all, just dies cleanly like the ECU told it to.
 

Registered
08 CTS with Sports Package and 165k miles
Joined
74 Posts
Discussion Starter · #12 ·
P0090 Fuel Pressure regulator 1 control circuit open.

Looks like either the new fuel pressure sensor I bought is a dud, or I have a loose connection. Time to dig in an find out!
 

Registered
2013 Black Diamond CTS4 Premium Coupe (sold-09 CTS4 DI Black Raven/Ebony)
Joined
5,053 Posts
Based on the complete loss of power, I hope it's a simple loose wire and it's also easy to find.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top