Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
hi
have tried a few times before no real solid answers as yet . well the engine still misses but att his time of year in arizona it runs great in the cool mornings. i actually went to emissions today and it passed much to my surprise. when warm weather comes again im sure it will go back to the steady miss. i have manuals , i understand cars but i would like some real answers on why after 10 20 30 miles the car goes nuts misses like hell. then can go back to being smooth. things seem to point to injectors but i cant find anyone who knows enough to tell me why they are intermittent other than possible small pieces of debris inside injectors but if that were the case why does it run so good when cool weather is here . it has 106k on it and when it wamrs up it still runs good but whacks out for a mile or two then comes back . there are times at the light i can hardly tell it is running . where do i start . can an injector suddenly change impedence? if so how can it come back and start working again a mile or two down the road. i am curious to know how often is a bad connection associated with the control modules ? is this fairly common ? should i start looking at those and pull and reconnect those and check all grounds ? i cant afford to just let the R&R mechanics just change things until it works . i suppose this will be my last attempt since ihavent had much luck getting some solid input in here. please understand that statement is not sarcasm i just need to find a guru if you will . i appreciate any answers that would help . please explain in any way you can will understand .
 

·
Registered
1995 FWB 124,*** miles
Joined
·
2,212 Posts
jocko777 said:
hi
have tried a few times before no real solid answers as yet . well the engine still misses but att his time of year in arizona it runs great in the cool mornings. i actually went to emissions today and it passed much to my surprise. when warm weather comes again im sure it will go back to the steady miss. i have manuals , i understand cars but i would like some real answers on why after 10 20 30 miles the car goes nuts misses like hell. then can go back to being smooth. things seem to point to injectors but i cant find anyone who knows enough to tell me why they are intermittent other than possible small pieces of debris inside injectors but if that were the case why does it run so good when cool weather is here . it has 106k on it and when it wamrs up it still runs good but whacks out for a mile or two then comes back . there are times at the light i can hardly tell it is running . where do i start . can an injector suddenly change impedence? if so how can it come back and start working again a mile or two down the road. i am curious to know how often is a bad connection associated with the control modules ? is this fairly common ? should i start looking at those and pull and reconnect those and check all grounds ? i cant afford to just let the R&R mechanics just change things until it works . i suppose this will be my last attempt since ihavent had much luck getting some solid input in here. please understand that statement is not sarcasm i just need to find a guru if you will . i appreciate any answers that would help . please explain in any way you can will understand .
Old ECM (computer) can act up when warm. It is under glove box, and very close to the heater core. You might try to remove the glove box and tap the ECM when it acts up to see if it makes difference.
 

·
Registered
did this once... 86 Deville, 86 300E, 78 R100rs
Joined
·
517 Posts
If the resistance/imedance of one/both of the injectors is off ENOUGH, it could cause the driver transistor to overheat and 'shut down' for the time it takes for it to cool off again.
Check the resistance of BOTH of the injectors to ensure they are close to the same value. I belive the book states what that value should be, or has been mentioned here before somewhere, but I don't know it off the top of my head....
If one of them is substantially different, that could force the issue you're seeing...
 

·
Registered
1992 Cadillac DeVille 4.9L
Joined
·
203 Posts
A possibility if you need new injectors is to get a set of ford 4.6L orange tops. They pop right in (from crown vic, lincoln towncar, etc). I did this and gained 2 MPG and a lot of power.
 
1 - 5 of 5 Posts
Top