Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
1993 STS
Joined
·
2 Posts
Discussion Starter #1
please help. I have a 1993 Cadillac Seville with 162k miles. I just purchased this car which is my first car I have ever had. I test drove it before I purchased it and drove fine. Today has been the first day i could actually drive it and now my car is stuttering between 2000-3000 rpms (misfire I guess you could call it). Drives fine no noises but when I go over 40mph and it hits 3000rpms it hesitates and starts stuttering. I don't know if it's bad gas, maybe needs new spark plugs, fuel injector? I haven't been able to take it anywhere because no mechanics are open right now. Does anyone know anything that can help me? I do not know much about cars. I love my car and would hate to get rid of it. Any info will help. Thanks
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,470 Posts
Your car has its own built-in diagnostic system for the OBD1 protocol. Please study the proper year/model group of instructions in the sticky post on this forum's main page - "How to pull codes". Write down any found codes and return to the sticky to open the link to definitions of all OBD1 codes. Almost everything on the car and engine is monitored for faults, so that's the place to start.

Depending on parts age and maintenance you could need any or several of a LOT of possible parts - ignition, air, or fuel related - most probably.

1993 STS - 4.6L Northstar ?

Thread moved to Seville from "STS-V". Very, very, very different vehicles. Please read the descriptive text in any forum title banner to find out what gets posted there.
 
1 - 2 of 2 Posts
Top