Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Silver Cadillac cts 2003
Joined
·
69 Posts
Discussion Starter · #1 ·
Recently my vehicle has been acting up. Everytime the car shifts gear it jerks also when it is downshifting, so i let it go for a while and it stopped for a few days but this morning when i was heading to work the engine light turned on and it started doing the jerking thing again, I took it to autozone, pepboys and o'reilly basically the gave me some codes and autozone guys as well as o'reilly said they had no idea what they meant told me to **** off basically lol and to take it to the cadi dealership but the tech guy at pepboys said that they are transmition codes and directed me to a transmision shop well point being idk what to do since i did research and some other people with similar problem and their solution was either throttle body the harness or sensor, so im all confused lol HELP :(


Here the codes:


p1779-Engine torque signal below lower limit detected.
p0221-throttle/pedal position switch B circuit range/performance.
p1795-throttle body position signal malcfuction.
p0700-malcfuction indicator lamp circuit malcfuction (TCM)
p2176-throttle position sensor minimum position not detected.

so what is your opinion on the situation
:banghead::(
 

·
Registered
O.G. CTS Sport/Lux, V Grilles/Bumpers, sittin on 20's
Joined
·
273 Posts
You might just need to clean your throttle body electric module, I've been having the same prob, check the thread I replied to today in the forum called 03 transmission
 

·
Registered
Silver Cadillac cts 2003
Joined
·
69 Posts
Discussion Starter · #4 ·
well seems like there alot of stuff to check well thx for the link
forgot ,just to put it out there b4 this happend my battery kept dying so i had to get a jump to start it two times one when i was leavin work n the next morning but i replaced the battery after the second time. next day this started week later engine light on
 

·
Registered
CTS 3.6L 2005 80,000 Miles
Joined
·
983 Posts
well seems like there alot of stuff to check well thx for the link
forgot ,just to put it out there b4 this happend my battery kept dying so i had to get a jump to start it two times one when i was leavin work n the next morning but i replaced the battery after the second time. next day this started week later engine light on
your throttle modulator may need calibrating, or is not working. there is an awesome thread on here from a guy who pulled his a part and cleaned it showing pictures and all.

Here you go have fun
 
1 - 5 of 5 Posts
Top