Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
2005 CTS 3.6L
Joined
·
7 Posts
Discussion Starter #1
Hey all, the guy who's trying to twin turbo his LY7 05 CTS here, I'm having a couple issues before the install of the turbines in the back end, thought y'all might be able to help.

So, she runs smooth and practically like a dream and she's got 214k on her, but a couple of issues arose recenty;

1.) Theres a rattle coming from the engine. A very noticible sound like it's out in the engine bay. I was thinking maybe a pulley or something.

2.) When she hits high rpm pulls say maybe 5500 to 6000, she sputters out and the throttle will stop working, or whenever I press the throttle, it seems to be choking out the engine because she idles perfectly fine when my foot is off the throttle. Hold it there long enough and she cuts out.

3.) Same throttle issue, but different scenario. She does that same throttle choke when I brake really hard.

I've already replaced the O2 sensors all around after datalogging her LTFT B2 was sitting happily at 19% and not fluctuating. Solved that issue.
And solved the P0420 & 430 codes by replacing the catalytic converters.

I've cleaned the injectors out meticulously, replaced the throttle body, the MAF sensor, the oil pressure sensor.

I've read that a vacuum leak can cause the same symptom as what I'm experiencing but everyone has a different scenario, so I went ahead and checked all of the vacuum lines.

I don't know if the Evap Canister is supposed to be making an audible ticking but I havent run any codes of it.

Her oil is changed every 3000 miles with Mobil1 Premium High Mileage Full Synthetic thats supposed to last 15000 miles or so it says, but can never be too careful.

If you can help that would be very much appreciated, thank you!
 

·
Registered
2005 CTS 3.6L
Joined
·
7 Posts
Discussion Starter #2
Update: Just ran a scan and pulled not a single code. I'm at a stopping point here.
 
1 - 2 of 2 Posts
Top