Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
586 Posts
Discussion Starter #1
engine cover. is it essential to put the grey plastic cover back on my motor? when i was working on my car yesterday i think i warped or something cus it wont go back on the motor.

does it need to be on there?
 

·
Registered
Joined
·
6,471 Posts
NO. It is really only there to give a "finished" look to the engine, and insulate some noise.
PS. if the cover doesn't fit, chances are you moved a harness or something that is now in the way. I doubt you "warped" the cover.
 

·
Registered
Joined
·
1,753 Posts
yeah i agree with katshot check to make sure any snaps are fitting properly over their cover, also this may seem like a no brainer but make sure ur putting in on the right way, sometimes u turn it around and sit their forever not realising your beigning stupid.
 

·
Registered
Joined
·
586 Posts
Discussion Starter #4
i was wondering if it held the oil pressure sending unit in place cus there are no bolts holding that in, it jsut pushed into the top of the intake manifold.

and i fugured out why it wont go back on. when i took it out, instead of the plastic nuts coming off on 2 of the screws for it, the entire screw untreaded from the intake.. so i had to kinds flex it a little to get under the cover to get it off.... to make a long story short, i bent 2 of the threaded studs that hold down. oh well...


i like how it looks without it anyway. My brother took his off his regal GS and found that without it the engine actually runs 10-15 degreese cooler. so i think its staying off... besides, this way if a kid in a honda asks what i have under there i can open it and try to convince him i put an LS1 in there sicne the intakes look very simmilar on the 2 motors. :D
 

·
Registered
White Diamond 2001 STS
Joined
·
1,317 Posts
AKPsiMC03 said:
i was wondering if it held the oil pressure sending unit in place cus there are no bolts holding that in, it jsut pushed into the top of the intake manifold.
I'm not sure what that would be...maybe the MAP sensor. The oil pressure sending unit is threaded into the oil filter adapter if I recall correctly.
 
1 - 5 of 5 Posts
Top