Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Based on what I have read regarding potential issues with smelly ac units, I requested my dealer to enable the after blow function on the HVAC unit. The service advisor told me today, that I was the first person ever to request this from their service department for my vehicle. When they attempted to turn this on in my vehicle, they were unable to do so without the help of GM. Maybe I'm being too paranoid even though I live on the dry west coast. But after reading about other people's experiences, I thought this was a good preventative measure to take.
 

·
Registered
14 CTS 2.0T, (traded 08 CTS 3.6)
Joined
·
136 Posts
I don't know how much time you've spent on forums, but my only piece of advice would be to not let other people's problems become your problems. This forum represents a very small and sometimes very vocal subset of CTS ownership.
 

·
Registered
'19 CT6 Platinum 3.0TT
Joined
·
497 Posts
I don't know how much time you've spent on forums, but my only piece of advice would be to not let other people's problems become your problems. This forum represents a very small and sometimes very vocal subset of CTS ownership.
I agree, I think most of the problems have been in high humidity areas like Houston and Florida. Seattle is known to be wet and it hasn't been a problem with me, and although I don't use the A/C much I do have the anti fog setting turned on so the A/C runs occasionally anyway to lower the humidity.
 

·
Registered
1994 Eldo TC, 1998 ETC, 1998 STS, 2014 CTS, 2016 CTS, 2017 CTS Premium AWD
Joined
·
387 Posts
I had this issue in Albany, NY, which is not usually regarded as high humidity. Turning on the after blow--which I think I only heard engage for the first time the other day--did help.
 

·
Registered
2016 XTS Premium
Joined
·
1,782 Posts
After almost a year I started to get the musty odors after my 14 CTS has been sitting for a while. Apparently related to new filter and design for 2014. No longer does the manual say how to replace and if I remember correctly, the cabin filtration system is identified differently in the listing of standard equipment. So whatever was changed appears to be why we are seeing this.
 
1 - 5 of 5 Posts
Top