Cadillac Owners Forum banner

1 - 20 of 22 Posts

·
Registered
2004 Deville
Joined
·
194 Posts
Discussion Starter #1
I am showing abs 1248 and 1214 codes in my 03 Deville. It is the ECBM. What part # is that , I would like to buy a used one and install it myself , is it hard to install ?
 

·
Registered
'98 STS (RIP @ 206,xxx miles)
Joined
·
4,854 Posts
I am showing abs 1248 and 1214 codes in my 03 Deville. It is the ECBM. What part # is that , I would like to buy a used one and install it myself , is it hard to install ?
WHOA. Make haste slowly when it comes to replacing modules. In the case of the EBCM your C1214 code is the cause of the C1248 code.

C1214 - System Relay Contact or Coil Circuit Open
C1248 - EBCM Turned the Red Brake Warning Indicator On

C1214 can be caused by corroded/oxidized/rusty pump motor ground connection. Double check the chassis ground connection for the black wire that exits the pump motor housing. Or maybe add a redundant chassis ground to a 2nd location.
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
No, it's not running. C1214 means the main power relay is inoperative.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,795 Posts
ABS and TC are basically one in the same and controlled by the same pump.
 

·
Registered
'98 STS (RIP @ 206,xxx miles)
Joined
·
4,854 Posts
ABS and TC are basically one in the same and controlled by the same pump.
Not quite.

ABS pulses the "driver applied" hydraulic pressure to the brake caliper at a wheel that is detected as spinning slower than expected. A pump is not required.

The Traction Control pump develops hydraulic pressure that is applied to the brake caliper on the drive wheel that is detected as spinning faster than expected.

ABS and Traction Control are mutually exclusive systems using the same module.
 

·
Registered
2004 Deville
Joined
·
194 Posts
Discussion Starter #11
Ground wire is perfect. Disconnected harness and cleaned. Codes and lights came back on ASAP . Can you replace the circuit board ?
 

·
Registered
2000 DTS 194,000 miles, 2000 DHS 203,000 miles
Joined
·
893 Posts
bobstanster said:
Ground wire is perfect. Disconnected harness and cleaned. Codes and lights came back on ASAP . Can you replace the circuit board ?
The most common problem with is EBCM is the relay inside it having broken solder points to the board. I have had several fixed for customers at work as well as my own by sending it into Myairbags.com. They will fix it and send it back to you within 24 hours of receiving it from you. Cost about 50 bucks plus shipping and has a lifetime warranty. You can even still drive the car with it removed.
 

·
Registered
1998 Cadillac Deville
Joined
·
854 Posts
And those codes are???
TCS C1234 DTC C1234 LR Wheel Speed Circuit Open or Shorted
TCS C1235 DTC C1235 RR Wheel Speed Circuit Open or Shorted

I figured it out... TCS Codes trigger the ABS and Traction Control lamps in the IC

Now Im still trying to figure out why....
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,292 Posts
TCS C1234 DTC C1234 LR Wheel Speed Circuit Open or Shorted
TCS C1235 DTC C1235 RR Wheel Speed Circuit Open or Shorted

I figured it out... TCS Codes trigger the ABS and Traction Control lamps in the IC

Now Im still trying to figure out why....
--------------------------------
you probably need two new rear hubs -

and you should have started your own thread -
rather than hijacking this one -
 

·
Registered
1998 Cadillac Deville
Joined
·
854 Posts
--------------------------------
you need two new rear hubs -

and you should have started your own thread -
rather than hijacking this one -
Apologize to the OP for the Hijack but thank you for the Answer to my problem Basscatt

I think that would explain why my Cruise Control works so Sporadically too
 

·
Registered
1997 Deville, 89 Camaro, 07 Silverado
Joined
·
363 Posts
super....i have and had the same problem...i showed same codes...i replaced left rear hub and still have codes...i have been told that it is the ebcm module that is causing problem. mayb same 4 u
 
1 - 20 of 22 Posts
Top