Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi, I'm new here so I hope I've got this post in the right forum. I've got a 1989 Brougham with a 5.0 litre V8 which I have recently purchased. Problem here has been that if I didn't drive the car for 3-4 days, the battery would go down and it would have to be jumped. Then it would charge and be ok until the next time I let it sit over the weekend. Last week, though, it got where it had to be jumped daily. Took it to Auto Zone this evening and the battery was reading 135 CCA, with the charging system putting out 14.5 Amps. They said the charge system was ok, so I replaced the battery with a 700 CCA model warranteed for 7 years.

My question is, could something be constantly drawing current from this battery when the car is off, thus pulling the battery way down, and if so what might I look for. Also, is 14.5 amps normal output for this charging system?

Battery I removed was dated March 2005, so it hadn't been in there long before I purchased the car in September.

Any ideas from experience would be greatly appreciated.

Thanks
CaddyLifer
 

·
Registered
1991 Cadillac Brougham D'Elegance 5.7 Litre, 1994 DeVille
Joined
·
6,796 Posts
The battery might just be bad. If your new one does the same thing come back here and do a search. There are tons of posts around about problems like that.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Thanks. Already been searching through and, as you said, many posts on subject. Guess I should have searched first! Again, thanks.
 
1 - 3 of 3 Posts
Top